Skip to Content
author's profile photo Former Member
Former Member

Command Groups issue

Hi all,

I have the following problem with Command Groups.

When I create a new Command Group or duplicatie an existing Command group I the iView I can see only the Default Command Group instead of the commands which I have assign. Even when I create a command group without any commands or when I duplicate the AppEmpty command group I see the default commands. When I change the commands of an existing command group, there is no change. When I use the existing command group there is no problem, but when I duplicate it, there are the default commands instead of the commands of the duplicated command group.

Another question. By searching, the option Similar Documents doesn't use the same collection renderer as the SearchResultLayoutSet. Can you tell me, which is the Collection Renderer of the Similar Documents.

Thanks in advance for any help.

Best regards,

Zlatina

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Aug 11, 2005 at 01:51 PM

    Hi

    you are doing perfectly fine what you need to do is duplicate the collection renderer and attach the commandgroup and then duplicate the layoutset and attach this collection renderer to it and apply this layoutset to iview by chaging the name of it in default layout.Hope this helps.allocate points just go through this soln i have posted earlier

    1.Identify the iviews which are used for xml forms

    here NEWS AUTHORING AND NEWS BROWSING.

    2.IN THIS REGARD U HAVE DISPLAYED LINKS OF REPOSITORY AT THE TOP OF AUTHORING IVIEWS WHICH CAN BE MASKED BY EDITING RENDERCONFIG.PROPERTIES FILE STORED AT ETC -XML FORMS FOLDER YOU CAN DIPLAY THE PROJECT IN THE IVIEW THAT U HAVE CREATED.

    3.GENERALLY LINKS WHICH ARE DISPLAYED AT THE BOTTOM OF THE IVIEW ARE CONTROLLED BY COMMAND GROUPS BY NAVIGATING

    You are here:

    Configuration

    Content Management

    User Interface

    Commands

    SELECT NEWS DISPLAY GROUP FOR NEWS BROWSER AND NEWS GROUP FOR NEWS AUTHORING CREATE DUPLICATE OF IT AND EDIT THE TAB COMMAND LIST FOR THE LINKS TO BE DISPLAYED AND NAME IT AS YOUR OWN COMMAND GROUP.

    4> NOW NAVIGATE TO

    Configuration

    Content Management

    User Interface

    Settings

    COLLECTION RENDERRER SETTINGS

    COLLECTION GRID RENDERRER SETTINGS

    DUPLICATE THE SETTINGS FOR NEWS COLLECTION RENDERRER AND NEWS DISPLAY COLLECTION RENDERRER AND ADD THE COMMAND GROUP U HAVE CREATED IN PREVIOUS STEP TO MASS COMMAND GROUP AND COLLECTION COMMAND GROUP PROPERTY FIELD

    5>U NOW HAVE TO CREATE THE LAYOUT THAT MEANS U ARE GOING TO APPLY A LAYOUT WHICH IS NOT DEFAULT BY NAVIGATING TO

    You are here:

    Configuration

    Content Management

    User Interface

    Settings

    LAYOUTSET

    DUPLICATE THE LAYOUT FROM THE AVAILABLE ONES FOR NEWS BROWSER AND NEWS EXPLORER NAME IT AND STORE IT IN A FILE

    NOW CHECK THE BOX SHOWING UR COLLECTION RENDERER IN PROPERTY WINDOW AND UNCHECK THE DEFAULT ONE SAVE IT

    5> GET IN PORTAL CONTENT DIRECTORY AND IN PROPERTY WINDOW EDIT THE LAYOUTSET OF NEWS AUTHORING AND NEWS BROWSER IVIEW ADD THE LAYOUTSET U HAVE CREATED JUST TYPE THE NAME OF IT . SAVE AND HAVE PREVIEW.

    <b>With regards

    subrato kundu

    IBM

    SAP Enterprise Portal technology consultant</b>

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Thanks a lot for your answer.

      The problem is in the Search Result LayoutSet not in the News Explorer or News Browser. The default commands of the SearchSingleItemGroup, which SearchResultRenderer uses

      are: browse_from_here,see_also_extern,.....

      I've duplicated the SearchResultItemGroup and changed the commands, than I've duplicated the SearchResultRenderer and I used the duplicated group SearchResultItemGroup_2.

      But when I use the new SearchResultItemGroup_2, I always get the commands copy,rename,delete,add to, favourites, sent to,local edit, online edit, similar documents, details. It doesn't matter which commands I have assigned to the the SearchResultItemGroup_2. When I use the default SearchResultItemGroup with the duplicated SearchResultRenderer, there is no problem. I also cannot change the default SearchResultItemGroup.

      With the CollectionRenderer the problem is that in the StandardSearchResultRenderer there are some displayed properties. But when I open similar documents link the displayed properties are not the same as in the default search. An exapmle: by default search there is rating, modifiedby,contentlength,modified, by similar documents these properties are not there. How can I change the displayed properties by similar documents?

      Thanks a lot for any help.

      Best regards,

      Zlatina

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.