Skip to Content

XS Engine on AWS, how to connect?

Hi guys,

Based on Thomas Jung his excellent YouTube tutorials I managed to create a ODATA service. However when I tried to test it in the browser I cannot seem to connect.

I used the following URL:

http://xxxxxx:8000/ALERTER/Services/sales.xsodata

xxxxx being my Amazon eleastic IP

ALERTER being my project, Services a folder and sales.xsodata my service.

Anything I need to do on the amazon security groups side (port 8000?)?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    Posted on Feb 10, 2013 at 02:36 PM

    That fixed it, but new issue... cannot seems to get the URL correct to test my service.

    URL:

    http://xxxxxxxxx:8000/alerter/services/sales.xsodata

    alerter being my package

    services a folder

    sales.xsodata my service

    All seems ok:

    but error 404

    Any ideas?


    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 10, 2013 at 12:59 PM

    Hi

    To get it working I added port 8000 to the security group. remember to use both the add rule and apply buttons.

    After that I get the xsengine is up and running at http://xxxxxx:8000

    Jan

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.