Skip to Content
0
Feb 06, 2013 at 12:59 PM

VS 2010 ClickOnce App does not work on Win 7 x64

288 Views

Use VS 2010 on 32-bit machine to create a ClickOnce app that uses Crystal Reports; the app targets x64 but with no prerequistes checked. The project includes references to these four Crystal libraries, but does not copy to local:

CrystalDecisions.CrystalReports.Engine.dll

CrystalDecisions.ReportSource

CrystalDecisions.Shared

CrystalDecisions.Windows.Forms

The development machine has got CRforVS_13_0_5.exe installed.

On a freshly-built Win 7 x64 computer, with .NET Framework 4.0 (Client and Extended) installed, along with the latest Microsoft updates, install CRRuntime_64bit_13_0_5.msi from CRforVS_clickonce_13_0_5.zip.

Install the ClickOnce app - this message is displayed:

"Unable to install or run the application. The application requires that assembly CrystalDecisions.ReportAppServer.CommonObjectModel Version 13.0.2000.0 be installed in the Global Assembly Cache (GAC) first"

On exploration of the Win 7 x64 computer, there is indeed no such file in the GAC.

The only location on the computer that has Crystal files is:

C:\Program Files (x86)\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Common\SAP BusinessObjects Enterprise XI 4.0\win64_x64

This location does not contain any file whose name starts with CrystalDecisions.

I have also tried the above test on a clean machine with the install file from CRforVS_redist_install_64bit_13_0_5.zip - same result.

Has anyone else got a different result?

Have I missed something out?