Skip to Content
avatar image
Former Member

component based alerts

Hi

we are at PI7.31 and enabled component based alerts. We are getting alerts from java like below for every 5 mins.
Any idea how to get rid of this alert meanwhile receive other useful alerts ?


1 messages failed for "SAP_PI_ALERT" on "af.XXX.XXXXXXXX"
Root cause: Alerting: Records deleted - Alert records deleted by Housekeeping [only used for alerting]

To navigate to the failed messages in the local message monitor use this link

The first 0 messages of that data collection:

{
"Component": "af.XXX.XXXXXXXX",
"ErrCat": "HOUSEKEEPING_ERROR_CATEGORY",
"ErrCode": "HOUSEKEEPING_ERROR_CODE",
"ErrLabel": "1033",
"ErrText": "21 alerts were deleted for component af.XXX.XXXXXXXX and rule ID fd2ab54d40f933b5ad2a2454e49e80d0",
"RuleId": "fd2ab54d40f933b5ad2a2454e49e80d0",
"Timestamp": "2013-01-31T22:20:07Z"
}

Thanks

Ravindra

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Mar 14, 2013 at 11:27 AM

    Hi Ravindra,

    There is a housekeeping job that checks the number and age of pending alerts, if it found too many / too old ones it will delete them all and repleace it with 1 entry of the message you are receiving.  You can configure the behavior of that task in the properties of the service "XPI Service: Alert".

    You can set the age and number of the alerts, and running interval of the job.

    You can find more info here:

    http://help.sap.com/saphelp_nw73ehp1/helpdata/en/05/1b2e99bbb640b0a0faf2444d8a457b/content.htm

    Nico

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Ravindra,

      I think the parameter "housekeeping.chunksHighVolumeThresholdInterval" will do it.  I havent tried myself, in my case i just increased the age and lenght thresholds. If it is suitable in your case , you can pick the alerts more often and that should work it as well.

      You may need to experiment a bit with those.

      regards,

      Nico

  • avatar image
    Former Member
    Feb 01, 2013 at 03:27 AM

    Hi Ravi!

    It seems you have enabled default rule in SAP PI ID.

    Disable it by opening default rule in ID.

    You can also check if any alertjob running in NWA->Operations management ->Jobs->Java scheduler and turn it off(by clicking on Remove/Release) in tasks tab.

    Hope this helps!

    Divyesh Vasani

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 01, 2013 at 03:39 PM

    Divyesh, Nice to see you here. Btw, we have not enabled DEFAULT_ALERTRULE in my system. But still we are getting this annoying alert for every 5mins. And even we didn't have any job's running other than AlertConsumerJob.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      AlertconsumerJob is the one.

      Stop / remove it if not required, as that sents the alerts to mail server.

      --> Go to Tasks tab and remove this task - AlertConsumerJob.

      Check Parameters tab, after selecting AlertConsumerJob.

      --Divyesh Vasani