Skip to Content

How to update the SAP UI5 libraries1.16.3 to the latest?

Hi All,

While trying to deploying the Fiori application to ABAP repository we came across the warning message about the SAP UI5 libraries incompatibility of the SAP system and application.We have the version on SAP system as 1.16.3 and application version as 1.26.3. Is it possible to upgrade the UI5 run time libraries from 1.16.3 to the latest version on the SAP system as the version is old.Our system is ECC 6.0 with Enhancement package 7(SAP Net weaver 7.4). Uploaded an image of the same problem.Could suggest any ideas/tips to upgrade the libraries to the latest one and also the prerequisites to achieve the above.

Thanking in advance,

Regards,

Ram.

sap-ui5-2.jpg (72.1 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Jan 06, 2017 at 03:19 PM

    Each UI5 version is the complete package, so you can go directly to the desired version.

    Regards,

    Jamie

    SAP - Technology RIG

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 06, 2017 at 07:45 AM

    Hi,

    You need to ask your basis team to do that.

    They can start maybe with some notes, example : 1933498-Upgrading version in ABAP system

    Maybe this will be helpful also: http://scn.sap.com/docs/DOC-62574

    Regards,

    Ovidiu

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 06, 2017 at 12:16 PM

    Hi Ovidiu,

    Thank you for the reply and the links posted. Need to upgrade from minor version 16 to latest minor version to the latest patch version.Do we need to find patches for 16 and upgrade and keep upgrading each minor version till the latest..or could we install the latest version itself.

    example: 1.16.3(Current). From this could we upgrade to 1.42.9(latest version according to SAP HANA) directly or do we have to install every version 1.2.*,1.3.*.

    Regards,

    Ram

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 07, 2017 at 12:49 AM

    Hi Jamie,

    Thank you for the reply. Will install the latest version directly.

    Regards,

    Ram

    Add comment
    10|10000 characters needed characters exceeded