Skip to Content
0
Former Member
Aug 08, 2005 at 09:53 PM

Fatal error importing a table for mapping

21 Views

Hello everybody:

I'm developing an study case applying MDM. I created like 10 tables in MS SqlServer and filled them with data. Afterwards, I learned that in order to import them into MDM I have to create a repository and re-create manually the same DB structure, since there doesn't seems to be a way to import that structure into MDM. Anyway, I did that and I'm on the import manager now.

I've managed to import 8 out of my 10 tables, mapping them all using the "auto-map" feature. Now, when I select the 9th table, I get an error (fatal one) message:

ImportManager.exe - Application Error

The intruction at "0x009016f4" referenced memory at "0x00000000". The memory could not be "read".

Click on OK to terminate the program

click on CANCEL to debug the program

A quite helpful message… It also happens with the other remaining table. I tried to map them first, and in any order I try to select them as SOURCE, the same error shows up.

The Structure of those tables is as follows:

On MS SqlServer:

Table name: ShoppingCarts

Fields:

User_id int size 4 Not null PK

Product_id int size 4 Not null PK

Date datetime size 8 Not null PK

Table name: Users_cart

Fields:

User_id int size 4 Not null PK

Cart_id int size 4 Not null PK

I don't think there's anything special with the tables structure, they are quite simple. I can select the DESTINATION part, but not the SOURCE part from Sql Server…. I get the same error everytime and the MDM Import Manager crashes.

Do you think I'm doing something wrong? I did import and mapped the other 8 tables…. Any advice?

Thanks a lot for your time and attention.