Skip to Content
0
Former Member
Jan 23, 2013 at 03:40 AM

TP command gives return code 0212 from OS

698 Views

Hi SAP Gurus,

My Transport domain and transport route has no issues and I was able to import transport requests from my DEV servers all the way to my PRD servers.

The import queue has no issues at this point of time.

my route is simple:

DEV -> UAT -> PRD

Currently I'm doing a mass import of TRs (5000 of them!!) from DEV to my UAT server. I decided to use the TP command at the OS level to execute and import the requests.

my OS command I used is:

tp addtobuffer DEVK123456 UAT pf=D:\usr\sap\trans\bin\TP_DOMAIN_DEV.PFL

tp import DEVK123456 UAT client100 U012689 pf=D:\usr\sap\trans\bin\TP_DOMAIN_DEV.PFL

However I got the following errors from the import command.

This is tp version 380.03.58 (release 720, unicode enabled)
Addtobuffer successful for DEVK123456
tp finished with return code: 0
meaning:
Everything OK
This is tp version 380.03.58 (release 720, unicode enabled)
This is R3trans.exe version 6.22 (release 720 - 18.11.11 - 11:29:00).
unicode enabled version
R3trans.exe finished (0000).
This is R3trans.exe version 6.22 (release 720 - 18.11.11 - 11:29:00).
unicode enabled version
R3trans.exe finished (0000).
Access denied on \\<PRD server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC (2)
\\<PRD server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC is already in use (1), I'm waiting 5 sec (20130110113949). My name: pid 12345 on <UAT Server> (uatadm)
Access denied on \\<PRD server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC (3)
\\<PRD Server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC is already in use (2), I'm waiting 4 sec (20130110113954). My name: pid 12345 on <UAT Server> (uatadm)
Access denied on \\<PRD server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC (4)
\\<PRD Server>\sapmnt\<PRD server>\SLOG1302.PRD.LOC is already in use (3), I'm waiting 5 sec (20130110113958). My name: pid 12345 on <UAT Server> (uatadm)
Access denied on \\<PRD server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC (5)
\\<PRD Server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC is already in use (4), I'm waiting 4 sec (20130110114003). My name: pid 12345 on <UAT Server> (uatadm)
Access denied on \\<PRD Server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC (6)
\\<PRD Server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC is already in use (5), I'm waiting 3 sec (20130110114007). My name: pid 12345 on <UAT Server> (uatadm)
Access denied on \\<PRD Server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC (7)
\\<PRD Server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC is already in use (6), I'm waiting 2 sec (20130110114010). My name: pid 12345 on <UAT Server> (uatadm)
Access denied on \\<PRD Server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC (8)
\\<PRD Server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC is already in use (7), I'm waiting 4 sec (20130110114012). My name: pid 12345 on <UAT Server> (uatadm)
Access denied on \\<PRD Server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC (9)
\\<PRD Server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC is already in use (8), I'm waiting 1 sec (20130110114016). My name: pid 12345 on <UAT Server> (uatadm)
Access denied on \\<PRD Server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC (10)
\\<PRD Server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC is already in use (9), I'm waiting 2 sec (20130110114017). My name: pid 12345 on <UAT Server> (uatadm)
\\<PRD Server>\sapmnt\trans\tmp\SLOG1302.PRD.LOC: Permission denied
PANIC --> exiting

tp returncode summary:

TOOLS: Highest return code of single steps was: 0
ERRORS: Highest tp internal error was: 0212
tp finished with return code: 212
meaning:
could not access file as supposed (see dev_tp or SLOG1302.PRD for more details)

When I checked the import history in STMS of my UAT server, the transport request is successfully imported to UAT. But when I check the import queue in PRD, the transport request is missing from the PRD import queue. The COFILE and DATA files were also not moved to PRD server when I try to add the request manually.

Am I missing some sort of authorization in PRD server? I ran the TP command using UATadm user ID (windows server).

Hope any of you can give me some advise on this. Thank you.

Regards,

Jansen