Skip to Content

HANA and OBIEE connectivity issue

Hi All,

We are trying to connect OBIEE BI Admin tool with HANA DB. The connection is successful add a connection. But while fetching sample data from a table, we are facing an error as mentioned here below.

[nQSError: 16015] SQL statement execution failed.

[nQSError: 16001] ODBC error state : S1000 code : -10808 message: [SAP AG][LIBODBCHDB32 DLL][HDB] General error; -10808 Feature (SCROLLABLE RESULT) not implemented yet in function module: d:\depot\bas\IMP\NEWDB100_REL\src/sys/src.

Has anyone tried this already and achieved successfully?

Please advice, thanks in advance.

Regards,
Chandu.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 22, 2013 at 10:53 PM

    Hi Chandu,

    I worked on a POC that included HANA and OBIEE connectivity. We received the same error that you have above and it's to do with the way that OBIEE generates its SQL statements. It uses a feature, as indicated in your error message, of SCROLLABLE RESULT. This is not support in SAP HANA. We did manage a workaround but it is rather convoluted and may or may not help you.

    It is possible to connect OBIEE to a Transient Provider in SAP BW on HANA. The Transient Provider on SAP BW on HANA is a direct connection to the Analytic View within SAP HANA. The connection from OBIEE to SAP BW is based on the standard SAP/BW 3.5/7.0 Data Source connection in OBIEE. This is an XMLA based connection which connects to SAP BW through a SOAP request.

    Out of interest, what version of HANA are you running. We did forward our findings to SAP and were hopeful that the ability to support Scrollable Cursors would become available at some stage.

    Regards,

    Gary Elliott

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Peer Huising

      Hi Sekhar,

           I know that OBIEE direct connectivity is not supported. I don't know if now is working (using HANA ver 85 or later).

      TIA and regards

      Marco

  • avatar image
    Former Member
    Aug 24, 2015 at 10:51 AM

    You get this error only in offline mode with the admintool, no ? (Ie with the windows odbc driver)

    For me, it works perfectly when I query a table on Linux.

    Message was edited by: Nicolas GERARD. Adding the OS diff.

    Add comment
    10|10000 characters needed characters exceeded