Skip to Content
0
Former Member
Jan 19, 2013 at 06:07 AM

Personnel Action Issue

361 Views

Dear All,

My issue is, I created a new Infogroup for PA40. The ref number existing was 40, and I have added one more Infogroup, i.e, Organizational Re-Assignment. Now, when i enter TCode PA40, and execute with this infogroup with a date to be copied, it gets saved with the new date and the same can be viewed in PA30/PA20 as well. The main issue here is the date gets changed, but the changes i make in Personnel Area, and Position, does not gets displayed the same way.

What I want to do is I want to change the Personnel Area of the Employees. I have created a new personnel area, assigned it to the company code as well. In PPOM_OLD, we have also created the Positoins. I follow the following steps:

1. Enter TCode PA40

2. Enter the Personnel Number, and the date (01.04.2012 in this case), select Organizational Re-Assignment (New Infogroup) and Execute.

3. Change the Position number, and Personnel Area.

4. Get a Warning Message -

No infotypes found. Maintain infogroup modifier/user group (in yellow)

5. Hit enter.

6. Pop Up appears, THIS ENTRY DELETES A RECORD.

7. Hit Enter again

8. Get a warning message in yellow:

Enter data for payroll past (retroactive accounting)

9. Save the entry

System says the record is created. When I check for the same in PA30, I do get a new entry with the date i entered in PA40 (01.04.2012), but the position and Personnel Area are the same as before.

Also, further I will like to know you that when I select EXECUTE INFOGROUP BUTTON in PA40, we get the warning "Warning: Personnel action infotype not saved
with 'execute info group' function! " in a new pop up window.

Kindly tell me, where I am going wrong in this situation.

Thanks