Skip to Content
0
Former Member
Aug 05, 2005 at 07:21 AM

Abap proxy call failed

399 Views

Hi,

I am trying to call (synchronous mode) from XI 3.0 an ABAP proxy located on a R3 enterprise 4.7 ext 2.00 server.

Unfortunately, when I send the request message with the XI Adapter to the local integration engine using message protocol 2.0,

an error occured on the R3 system:

PROTOCOL.LOOP_IN_MESSAGE_ROUTING

...

http://sap.com/exchange/MessageFormat">

<SAP:Context></SAP:Context>

<SAP:Code p1="is.00.hermes" p2="IS" p3="XI" p4="">PROTOCOL.LOOP_IN_MESSAGE_ROUTING</SAP:Code>

<SAP:Text language="EN"></SAP:Text>

</SAP:ErrorHeader>

http://sap.com/exchange/MessageFormat" Version="1.0">

<SAP:Hop SystemName="is.00.hermes" Type="CENTRAL" TimeStamp="2005-08-04T18:11:25Z" WasRead="0">

<SAP:MessageInbound>

<SAP:Type></SAP:Type>

<SAP:AdapterRefId>3.0</SAP:AdapterRefId>

<SAP:MessageId>2B1B2E10-0513-11DA-A979-0013216B8075</SAP:MessageId>

</SAP:MessageInbound>

<SAP:MessageOutbound>

<SAP:Type>IENGINE</SAP:Type>

<SAP:AdapterRefId>3.0</SAP:AdapterRefId>

<SAP:MessageId>2B1B2E10-0513-11DA-A979-0013216B8075</SAP:MessageId>

</SAP:MessageOutbound>

</SAP:Hop>

<SAP:Hop SystemName="is.00.hermes" Type="CENTRAL" TimeStamp="2005-08-04T18:11:25Z" WasRead="0">

<SAP:MessageInbound>

<SAP:Type>IENGINE</SAP:Type>

<SAP:AdapterRefId>3.0</SAP:AdapterRefId>

<SAP:MessageId>2B1B2E10-0513-11DA-A979-0013216B8075</SAP:MessageId>

</SAP:MessageInbound>

<SAP:MessageOutbound>

<SAP:Type></SAP:Type>

<SAP:MessageId>2B1B2E10-0513-11DA-A979-0013216B8075</SAP:MessageId>

</SAP:MessageOutbound>

</SAP:Hop>

<SAP:Hop SystemName="UPG" Type="RECEIVER" TimeStamp="2005-08-04T18:11:25Z" WasRead="0">

<SAP:MessageInbound>

<SAP:Type>IENGINE</SAP:Type>

<SAP:AdapterRefId>2.0</SAP:AdapterRefId>

<SAP:MessageId>2B1B2E10-0513-11DA-A979-0013216B8075</SAP:MessageId>

</SAP:MessageInbound>

<SAP:MessageOutbound>

<SAP:Type>PROXY</SAP:Type>

<SAP:MessageId>2B1B2E10-0513-11DA-A979-0013216B8075</SAP:MessageId>

</SAP:MessageOutbound>

</SAP:Hop>

</SAP:HopList>

http://sap.com/exchange/MessageFormat" version="1.0" SOAP:mustUnderstand="1">

<SAP:From>

<SAP:Name>WebServer</SAP:Name>

DataUserQuery_outhttp:// DataUserQuery_out" target="_blank">adixen.fr/test">DataUserQuery_out>

</SAP:From>

<SAP:To>

<SAP:Name>UPG</SAP:Name>

DataUserQuery_inhttp:// DataUserQuery_in" target="_blank">adixen.fr/test">DataUserQuery_in>

</SAP:To>

<SAP:MessageId>2B1B2E10-0513-11DA-A979-0013216B8075</SAP:MessageId>

<SAP:QualityOfService>BestEffort</SAP:QualityOfService>

<SAP:TimeSent>2005-08-04T18:11:24Z</SAP:TimeSent>

<SAP:Direction>Response</SAP:Direction>

<SAP:Document></SAP:Document>

</SAP:MessageHeader>

http://sap.com/exchange/MessageFormat">

<SAP:AdapterInbound>PROXY</SAP:AdapterInbound>

<SAP:AdapterOutbound>IENGINE</SAP:AdapterOutbound>

</SAP:InternalAttributesHeader>

</SOAP:Header>

http://schemas.xmlsoap.org/soap/envelope/">

http://sap.com/exchange/MessageFormat" xmlns:xlink=" http://www.w3.org/1999/xlink" version="1.0">

payload-AF6BAB03175A80449497B3122C844D44@sap.com">

<SAP:Document>TraceDocument</SAP:Document>

</SAP:Payload>

</SAP:Manifest>

</SOAP:Body>

--SAP_41F726EA34ED2F498C6BA328BAB08C43_ENDcontent-type:text/plaincontent-length:2912content-id:payload-AF6BAB03175A80449497B3122C844D44@sap.com

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

http://sap.com/exchange/MessageFormat">

<Trace level="1" type="B">CL_XMS_TROUBLESHOOT-ENTER_PLSRV</Trace>

<Trace level="1" type="E">CL_XMS_TROUBLESHOOT-ENTER_PLSRV</Trace>

<Trace level="1" type="T">**************************************************** </Trace>

<Trace level="1" type="T">* * </Trace>

<Trace level="1" type="T">* * </Trace>

<Trace level="1" type="T">XMB entry processing </Trace>

<Trace level="1" type="T">system-ID = UPG</Trace>

<Trace level="1" type="T">client = 100</Trace>

<Trace level="1" type="T">language = E</Trace>

<Trace level="1" type="T">user = YLEBLEVEC</Trace>

<Trace level="1" type="Timestamp">2005-08-04T18:11:25Z </Trace>

<Trace level="1" type="T">* * </Trace>

<Trace level="1" type="T">* * </Trace>

<Trace level="1" type="T">**************************************************** </Trace>

<Trace level="1" type="B">CL_XMS_MAIN-CALL_UC_EXECUTE</Trace>

<Trace level="1" type="T">Message-GUID = 2B1B2E10051311DAA9790013216B8075</Trace>

<Trace level="1" type="T">PLNAME = SENDER</Trace>

<Trace level="1" type="T">QOS = BE</Trace>

<Trace level="1" type="B">CL_XMS_MAIN-CALL_PIPELINE_SYNC</Trace>

<Trace level="1" type="T">Get definition of pipeline PID= SENDER</Trace>

<Trace level="1" type="B">CL_XMS_MAIN-WRITE_MESSAGE_LOG_TO_PERSIST</Trace>

<Trace level="1" type="E">CL_XMS_MAIN-WRITE_MESSAGE_LOG_TO_PERSIST</Trace>

<Trace level="1" type="B">PLSRV_CALL_INTEGRATION_SERVER</Trace>

<Trace level="1" type="B">CL_XMS_MAIN-CALL_PLSRV</Trace>

<Trace level="1" type="B">CL_XMS_MAIN-CALL_PLSRV_LOCAL</Trace>

<Trace level="1" type="B">CL_XMS_PLSRV_CALL_XMB-ENTER_PLSRV</Trace>

<Trace level="1" type="T">URL for integration server read from global configuration </Trace>

<Trace level="1" type="T">URL= dest://INTEGRATION_SERVEUR</Trace>

<Trace level="1" type="B">CL_XMS_MAIN-SET_TECHNICAL_ROUTING_PROPERTY</Trace>

<Trace level="1" type="E">CL_XMS_MAIN-SET_TECHNICAL_ROUTING_PROPERTY</Trace>

<Trace level="1" type="B">CL_XMS_PLSRV_CALL_XMB-CALL_XMS_HTTP</Trace>

<Trace level="1" type="E">CL_XMS_PLSRV_CALL_XMB-CALL_XMS_HTTP</Trace>

<Trace level="1" type="E">CL_XMS_PLSRV_CALL_XMB-ENTER_PLSRV</Trace>

<Trace level="1" type="E">PLSRV_CALL_INTEGRATION_SERVER</Trace>

<Trace level="1" type="E">CL_XMS_MAIN-CALL_PIPELINE_SYNC</Trace>

<Trace level="1" type="B">CL_XMS_MAIN-WRITE_MESSAGE_TO_PERSIST</Trace>

<Trace level="1" type="E">CL_XMS_MAIN-WRITE_MESSAGE_TO_PERSIST</Trace>

<Trace level="1" type="E">CL_XMS_MAIN-CALL_UC_EXECUTE</Trace>

<Trace level="1" type="E">CL_XMS_MAIN-ENTER_XMS</Trace>

<Trace level="1" type="E">CL_XMS_HTTP_HANDLER-HANDLE_REQUEST</Trace>

</SAP:TraceHeader> SAP_41F726EA34ED2F498C6BA328BAB08C43_END

I guess the error occurs before the call of my proxy. Can anyone help?

Thanks,

Yann