Skip to Content
author's profile photo
Former Member

An urgent problem of the deploy tool!!

Hi all,

I used the deploy tool to create a new EAR.In the Assembler tab, I built the EAR successfully and an EAR file appears in the workplace folder.But when I'm going to deploy this EAR,the EAR file is deleted from local machine and I get a message which reads "Can't find the EAR".What do the deploy tool?How can it delete the EAR file and give the message of finding no EAR?How to explain this?

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • author's profile photo
    Former Member
    Aug 05, 2005 at 06:02 AM

    Hi Holden,

    Have you Saved JAR,WAR and WAR in to local workspce folder before deploying.

    Save the application, rebuild and deploy may solve your problem

    Regards,

    RK

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Aug 05, 2005 at 06:20 AM

    Hi Zhang,

    This problem will occur due to some configuration settings with the Studio.Even tough you save all your jar,war & ear file it will get deleted when you deploy since the environment is not properly set.

    Did you try building ear file for another sample dummy application with the studio?Is the problem arises only for the current project or for all esr files.

    If you get problem for all ear files then,please do as below.

    I suggest you to re-install the studio once again.But before doing so clear your registry entries also in your local machine for the older version.

    It shd definitely work.

    Regards,

    Guru

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Oct 05, 2005 at 05:55 AM

    I have the same problem the ear file is deleted after some error during the deployment.

    What I do is .. rebuild the ear file and deploy again.. this time is working.

    The deployment failed during connect to the J2EE engine.. then I noticed u must make sure start the J2EE Server in the SAPMMC.

    Add comment
    10|10000 characters needed characters exceeded