Skip to Content
avatar image
Former Member

Create leave request in EhP6 on NWBC

Hi,

We are on Ehp6 and using the NWBC to access the ESS/MSS services. All the services are working fine except the Create Leave Request. Only half of the application is rendered as below:

The leave details is not being loaded at all. Please let me know what am I missing here.

Thanks,

Balajii

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 23, 2013 at 08:36 AM

    Hi Balaji

    On EHP5 the Leave Details are only rendered if there is Leave Request customising set up for the user in question. A missing IT0105 user record or an incorrect rule group determination could also cause this. Please check if the Leave Request customising is in place for the user's PSG.

    Best regards,

    Martin Søgaard

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 17, 2013 at 06:08 PM

    is your employee assigned the role SAP_EMPLOYEE_XX_ESS_WDA_1 ?

    Please check this ie user in 0105 0001 should have this role maintained in under user tab in pfcg for this role, you can test the application from there

    and also it appears below leave details ie creation

    you can execute from pfcg with right click in configure mode ie if something is hidden extra

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Siddharth Rajora

      Hi Siddharth,

      The application doesn't load even in the browser. I have tested the application in browser and NWBC for HTML from SE80, and this doesn't work anywhere. I am hoping the problem is with the application instead of NWBC

      We are on SAP_ABA 731 0004.

      This might be my career shift 😊 but not without your help here 😉.

      Thanks,

      Balajii

  • avatar image
    Former Member
    May 18, 2016 at 11:52 AM

    Hi Siddharth,

    We are facing same problem in NWBC. This blank screen is coming only for one employee. i checked below things , all are in place but still getting blank screen.

    necessary roles are assigned ,there is no hidden item for the employee in nwbc. data is there in v_t554s_web.

    PFB Screenshot of 0105 and 2006 infotype. Not able to find out the cause. please help.


    IT0105.PNG (5.8 kB)
    2006.PNG (10.9 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • its an issue with employee data hence occuring for him only

      In the dump you can get further information what is missing. you can debug from PTARQ itself as you did above.

      Just check his leave requests from earlier on ie rptarqdbview and his infotypes