Skip to Content

Delete instances after N days

Description of Problem:

I am trying to set the limit for instances of Crystal reports in the CMC. For the users who want to save only the last N instances of an object, I have no problems. I select the checkbox for "Delete excess instances when there are more than N instances of an object", input the max value, and it works great. However, I have other users who want their reports saved for the last year (and they run their reports sporadically). When I select "Delete instances after N days for the following users/groups", I select the Administrators group and the applicable user group(s). For the "Maximum instance age in days", I give it a value of 365. None of the reports that are older than a year get deleted. I am setting limits at the lowest-level folder for 3 report folders, and then I'm setting limits at the report level for the 4th folder.

Product: BO XI 3.1 Enterprise, Product 12.1.0

Sporadic or Consistent: Consistent

What has already been tried:

1. After setting the limits, I scheduled the reports to "Run Now" to trigger the instance purge. That worked for the "Delete excess instances when there are no more than N..." limit setting, but didn't work for the setting "Delete instances after N days..."
2. I had our server team reboot the server last night. Still no luck.

Add comment
10|10000 characters needed characters exceeded

  • It should definitely have completed by now, if you changed it weeks ago.

    Nothing else I can think of that would cause that behavior, apart from a bug. There were some known issues with instance limits in BI4, but none that I found for XI3 (of course, that doesn't mean that there weren't any).

    Have you tried it with other reports? I would try setting up a daily schedule, and setting the limit to a low value - like three days. At least that would tell you if the functionality is working.

  • Good idea. I'll give that a try and see what happens.

  • Just wanted to report back that I tried setting up a new report on a daily schedule with limit set to 3 days. Didn't work. I'll keep searching to see what the issue might be.

  • Get RSS Feed

0 Answers