Skip to Content
avatar image
Former Member

CacheServers running with errors

Hi all

Currently, the BO 4.0 install is running fine, however the CrystalReportsCacheServer and DashboardDesignCacheServer are showing state: "Started with Errors"

When I look at their properties, it says: This server has configuration errors.

Creating new servers has the same message.

The logs show:

---------------------------------------------------

trc file: "crcache_BIDEV.CrystalReportsCacheServer_ncs.trc", trc level: 1, release: "720"

---------------------------------------------------

M

M [Thr 7244] Wed Jan 16 10:53:09 2013

M [Thr 7244] ***LOG Q0I=> NiPGetHostByName: '$SMDAgentHost' not found: getaddrinfo [ninti.c 895]

M [Thr 7244] *** ERROR => Main agent failed to be initilized due to incorrect host setting! [ncsmtdatasen 20]

M [Thr 7244] *** ERROR => Main agent failed to be initilized due to incorrect host setting! [ncsmtdatasen 20]

M [Thr 7244] NCS trace timer is disabled since the interval is set to 0

M [Thr 7244] NCS data timer is disabled since the interval is set to 0

M [Thr 7244] NCS library version 2.3.9 (unicode) loaded

M [Thr 7244] NCS_ProcInit API invoked

--- Just noticed, a lot of the trace logs have this message, however only those two servers are reporting configuration errors.

Any ideas?

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 16, 2013 at 03:07 AM

    This may be an issue with the EnterpriseFramework.dll. If this dll gets registered while the SIA is running, this is one of the causes of this error.

    To resolve this,

    Stop your SIA

    Start > Run

    regsvr32 -u "<dir>:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\win64_x64\EnterpriseFramework.dll"

    regsvr32 "<dir>:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\win64_x64\EnterpriseFramework.dll"

    Start your SIA.

    Hope this helps.

    Regards,

    Mrinal

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 17, 2013 at 02:36 AM

    Hi Zelman,

    When did this issue start?

    As in did you make any change in the server after which you noticed this issue or was this from the very beginning itself?

    Regards,

    Mrinal

    Add comment
    10|10000 characters needed characters exceeded