Skip to Content
author's profile photo Former Member
Former Member

Code Completion not working

Hi ,

When i am trying to use code completion tool in Eclipse, its not working properly. When i click ctrl + space , i see list of methods or function module(as well as i can see signatures). But , when i press shift+enter , as mentioned in document , i just get the function module name or method name in my program. The code completiong doesnt get all the parameters.

How do i resolve this issue.

Thanks

Madhumati

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    Posted on Jan 18, 2013 at 08:04 AM

    Hi Madhumati,

    I'm having exactly the same issues as you describe. I seem to have just found a workaround that works sometimes:

    When calling the code completion from the class and selecting the method, Shift + Enter inserts the method name but not the signature.

    However if you immediately call code completion again, and hit Shift + Enter, it (sometimes) inserts the signature propperly.

    Regards,

    Gerald

    P.S. @Felix: I'm also running GUI 730, but Eclipse 4.2 (Juno)

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 21, 2013 at 11:53 AM

    Hi Madhumati,

    it would be great if you could give us some more information which should help us troubleshoot the problem.

    1) Please open the "ABAP communication log" view via menu "Window->show view". Switch on the log by clicking on the green play button. The log shows you the requests which the client fires against the backend. When the code insertion works the log has the following entries.

    POST /sap/bc/adt/abapsource/codecompletion/insertion?uri=XXXXXXX

    POST /sap/bc/adt/abapsource/codecompletion/elementinfo?uri=XXXXXXX

    POST /sap/bc/adt/abapsource/codecompletion/proposal?uri=XXXXXXXX

    Please reproduce the bug and post your log entries here. Does the client send the "insertion" request?

    2) Please open the "Error Log" view via menu "Window->show view". After executing the broken functionality see if new entries did appear in the error log.

    3) Since the code completion gets executed in a background thread there might be errors happening in the backend which you are not aware of. Please check whether the bug produces shortdumps in the backend via transaction st22.

    regards,

    Thomas

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 14, 2013 at 08:42 AM

    Hi Madhumati,

    we need some details to reproduce the issue.

    Which version of Eclipse do you use?

    For which function module did you try to get the signature to be inserted (is it local, is it a name space, ...)?

    Regards, Felix

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Felix,

      I am using Eclipse Indigo. SAP GUI is 730.

      I have created a class with 2-3 methods as local object . I have tried to use auto completion for these methods , which didnot work.

      Then i tried to call 'BAPI_SALES_ORDER_CREATE' using code completion , which didnt work either.

      When i press shift+enter , the pattern(importing/exporting parameters) doesnt get copied.

      Thanks

      Madhumati

  • Posted on Jul 23, 2016 at 01:10 PM

    Hi All.,

    this is a just info for Eclipse users,

    if you want to insert the signature on completion and it does not wok, just active the box in eclipse.

    Regards

    Ebrahim


    signature.PNG (31.3 kB)
    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.