Skip to Content
0

-8037 Failed to connect or logon to SLD, please check connection parameters and configure file

Jan 05, 2017 at 04:56 PM

401

avatar image

Hi everyone,

I have a problem connecting to SAP b1 using SDK (DI API).

my application worked before with no problems (for at least 3 years). all of the sudden i got this error.

I run windows 7 on my machine. I have tried to uninstall the API and reinstall it again.

Also checked the server name in the SLD and it's the same server.

I have the server name in (b1-local-machine) not the (localhost).

my connection looks like:

vCmp = new SAPbobsCOM.Company();

vCmp.Server = "SAP";

vCmp.DbServerType = SAPbobsCOM.BoDataServerTypes.dst_MSSQL2008;

vCmp.CompanyDB = "company";

vCmp.UserName = "manager";

vCmp.Password = "******";

vCmp.LicenseServer = "SAP:30000";

vCmp.language = SAPbobsCOM.BoSuppLangs.ln_English;

vCmp.DbUserName = "user1";

vCmp.DbPassword = "******";

vCmp.Connect();

ConnectStat =vCmp.Connect();

I have tried all the suggested solutions I found on-linw with no luck

please advise

Thank you

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Edy Simon Jan 06, 2017 at 12:44 AM
0

Does this windows 7 machine has the SAP Client install?
Can the SAP Client connect ?
Can any of the SAP standard Add-on run ?

Regards
Edy

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi Edy,

what do you mean by "SAP Client"?

the Win7 machine I use as a development box for web/desktop apps.

I used to run all kind of SAP apps. using SDK with no problem just till the last week.

I have already installed B1DIAPI (32 Bit) long time ago , removed it an reinstall again.

I even checked the SLD on the SAP server, all looks good.

Thanks,

Samira

0

Hi Samira,

SAP Client is the SAP UI Application.
Reason for me asking is to make sure the problem is not the SAP Installation.
If your SAP Client + SAP Standard Addon also does not run, most probably it is because of windows update.
If your SAP Client + SAP Standard Addon does run, we will need to look for other cause.

BTW, which SBO version are you using ?

Regards
Edy

0

Hi Edy,

Thanks for your reply. SAP client works fine and is on separate machine.

SAP SBO version is: 9.02.002

Thanks,

Samira

0