Skip to Content
avatar image
Former Member

error in sending idoc

Hello..

i getting error in R/3 while i'm sendin IDOC to XI using sender RFC adapter error is... "Use IDOC Adapter for FM IDOC_INBOUND_ASYNCHRONOUS"...

Can any one help me anything went wrong?

Thanks

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Aug 03, 2005 at 10:06 PM

    Hi,

    1. you don't use any adapter if you're seding IDOCs to XI

    just specify the R/3 port to XI in SM59 (on the R/3 side)

    and that's it

    (that's why in the IDOC adapter Sender field is greyed out)

    2. if you want to send IDOC from XI then you use IDOC adapter

    Regards,

    michal

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Michal Krawczyk

      Hello..

      Sending R3 System >XI >Webservices Scenario..

      I created like...

      SM59 rfc dest to int server (Type 3) // Sending System

      WE21 tRFC port // Sending System

      BD54 receiver sys as logical system // Sending System

      SM59 RFC Dest to Sending sys from IS.(Type 3) //Int. Server

      IDX1 Port Maintenance //Int. Server

      IDX2 Load Metadata of IDoc //Int. Server

      WE20 partner profile (o/b parameters) // Sending System

      WE19 IDoc o/b processing // Sending System

      I. getting error like..no service in intigration directory...

      am i missing some thing?can any one tell me?

      Thanks...

  • avatar image
    Former Member
    Aug 04, 2005 at 01:40 PM

    Hi,

    Please check whether your XI system has been defined as Integration Server (TA "sxmb_adm" -> Integration Engine Configuration -> Role of Business system = "Integration Server").

    Best regards

    Joachim

    Add comment
    10|10000 characters needed characters exceeded