Skip to Content
avatar image
Former Member

issues in sldcheck and sldapicust

Hi All,

I am unable to launch the nwa or j2ee start page when i give sldcheck in new PI7.3(abap+java) system  .Below are the errors.I have tried with users sldapiuser and slddsuser,piappluser.It is not working fine.I have assigned the necessary role to piappluser,slddsuser and sldapiuser.But still facing issues when i give sldcheck and sldapicust too.

SLDCONNECTION TEST via SLDAPICUST

SLD Connection Test

Communication mode: RFC + HTTP (deprecated)

Properties of RFC destination SAPSLDAPI

  RFC host:        %%RFCSERVER%%

  Program ID:      SAPSLDAPI_PIR

  Gateway host:    **********

  Gateway service: sapgw00

Testing RFC connection to the SLD java client...

RFC ping was successful

SLD destination settings:

  Alias:       SAP_CONFIG

  Host name:   *************

  Port number: 50000

  User:        sldapicust

Testing HTTP connection to the SLD server...

An exception has occurred:

Exception in SLD client: AbapSLDRequestHandler.ping(): CIM_ERR_FAILED: User credentials are invalid or user is denied acces

#############################################################################################################

SLDCHECK::

Exchange Infrastructure: Test LCR Connection

Communication mode: RFC + HTTP (deprecated)

Properties of RFC destination SAPSLDAPI

  RFC host:

%%RFCSERVER%%

  program id:      SAPSLDAPI_PIR

  gateway host:      ******

  gateway service: sapgw00

Testing the RFC connection to the SLD java client...

RFC ping was successful

SLD destination settings:

  Alias:       SAP_CONFIG

  Host name:   *******

  Port number: 50000

  User:        sldapicust

Use transaction SLDAPICUST if you wish to maintain the SLD server access data

Launching the SLD GUI in a separate browser window...

=> Verify in the browser GUI that the SLD is in a healthy running state!

Calling function LCR_LIST_BUSINESS_SYSTEMS

Retrieving data from the SLD server...

Function call returned exception code     4

=> Check whether the SLD is running!

Summary: Connection to SLD does not work

=> Check SLD function and configurations

Regards

basis

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 05, 2013 at 04:56 PM

    Hi basis,

    The below sapnote will resolve the issue

    Note 1244841 - SLD API: Error during connection test.

    With Regards

    Ashutosh Chaturvedi

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Ashutosh,

      Maintained the hostname in the server as well as in the desktop too.SLDCHECK is working fine.

      Thanks a lot for valuable help .....

      Points will be rewarded shortly

      Regards

      Ram

  • avatar image
    Former Member
    Jan 03, 2013 at 09:30 AM

    Hi Basis,

    Please follow below link.

    http://scn.sap.com/thread/1480374

    With Regards,

    V Srinivasan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Srini,

      As per the above mentioned link, the service users PIDIRUSER, PILSUSER, PISUPER,PIAPPLUSER are done during installation ,but these users are not getting reflected at the ABAP end

      Therefore i created the user PIAPPLUSER manually at the abap end and grnated the SAP_XI_APPL_SERV_USER too.I created the sldapiuser and slddsuser with same role and still i have connection issues

      Let me know what next can i do,,,,,,,Can i create manually them at ABAP end

      Regards

      Basis

  • avatar image
    Former Member
    Jan 03, 2013 at 09:34 AM

    Hi All,

    i have checked the rfc connection of SAPSLDAPI and LCRSAPRFC .The connection seems to be fine too.I have checked the rfc connection to integration server and that is fine with user PIAPPLUSER too,But getting issues only with SLDAPICUST and SLDCHECK.I have used same user PIAPPLUSER and tried again.....it not working properly and giving the same errors as above

    Kindly provide me any solution

    Regards

    Basis

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Ashish Mishra

      Hi Ashish Misra

      I have tested with PIAPPLUSER and i have maintained the hostname and port number too

      Testing HTTP connection to the SLD server...

      An exception has occurred:

      Exception in SLD client: AbapSLDRequestHandler.ping(): CIM_ERR_FAILED: HTTP response code: 403 Forbidden

      Iam still facing issue with this ....Let me know what further i can do

      Regards

      Basis

  • avatar image
    Former Member
    Jan 03, 2013 at 06:13 PM

    Hi basis,

    1. When you run the NWA Configuration wizard for SLD, then it will create the SLD user and it will create the entry automatically.

    2. Run the transaction SLDAPICUST.

    3. Maintain the user SLDAPIUSER or SLDDSUSER , its password and the port number.

    4. Perform the test connection over there.

    Moreover , check whether you can access the port 50000 from the server to the sld server.

    Check by telnet.

    telnet <hostname for sld> 50000

    Since its linux you can give a try with this command.

    nc -z <sld fully qualified name> 50000

    If connection get failed to 50000 port by using the above command . then ask the os team to open the port 50000.

    With Regards

    Ashutosh Chaturvedi

    With Rega

    Add comment
    10|10000 characters needed characters exceeded