Skip to Content
0
Former Member
Dec 27, 2012 at 03:06 PM

.Net Viewer - Generated report not showing grouped section values and fields overlap

19 Views

I am able to successfully generate reports via the browser using the .Net viewer, however when the report is generated the group names do not show and the alignment of the fields in some sections is off or overlaps other fields. I have tried several methods that I found within the forums to resolve the issue, but none of these has worked. These include:

1) Setting the fields to can grow and limiting it to one line ( Note 1207237 )

2) Modifying the webconfig file to allow text clipping ( Note 1535833 )

3) Adding an intermediate page to capture the DPI value and set it prior to rendering. ( Note 1421021 or 1372993 )

4) Downloaded and installed SP4:

Support Pack 4

(v. 13.0.4.x)

SP 4 Fixed Issues Wiki 32bit_13_0_4.msi 64bit_13_0_4.msi 13_0_4.msm clickonce_13_0_4

This only appears to affect the viewer as I can export the report from the viewer to a PDF and it is formatted correctly. Attached are two screenshots (GoodFormatting.jpg - generated in crystal designer and BadFormatting.jpg - generated in .Net viewer) of the report that show what it should look like and what it looks like from the viewer. Any help on this is greatly appreciated.

Thank you,

Shawn

.Net Framework 4.0 & 4.5

Crystal Reports 2011 v14

Visual Studio 2010 and 2012

OS: XP,Win7, Server 2008 R2

Attachments

BadFormatting.jpg (141.5 kB)
GoodFormatting.jpg (144.6 kB)