Skip to Content
author's profile photo Former Member
Former Member

Query Cache with Reporting Agent

Hi,

I created a web report, a control query and a reporting agent Web template setting. Control Query is designed to have Plant in the row and Profit center hierarchy on the columns. Web Query is drilldown by Plant and Material.

With this, I thought I would be in a position to run the reporting agent once and access the subset of the data from the cache.

When I schedule the reporting agent for web template, I could see the results in transaction RSRAPS.

However, when I run the query from the browser with DATA_MODE=HYBRID and select a profit center hierarchy node with couple of plants, I see that the data is not being accessed from the cache rather it goes to get the data from the data base.

Would appreciate any help in fixing this problem.

VJ Sudharsan

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Aug 02, 2005 at 05:14 AM

    Hi,

    Did you check the query cache settings in RSRT? This should be set to one of the cache options.

    The variables that you use in the report, these should have the check box on for changeable during navigation.

    After this, rerun the query and you should see an entry for the query in RSRCACHE. In the selection variable/hierarchy level you should be able to see the values or range of values that you had used to execute the query.

    From then on you would be able to use the cache.

    Another point is the cache gets invalidated due to a number of reasons such as data loads, attribute change run, query definition change and so on.These factors need to be taken into account while setting up and reusing cache.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 03, 2005 at 09:54 PM

    Hi sudharshan ,

    how do u know that , it is going against the cube instead of cache. Have you tried with DATA_MODE=stored and is it says 'No precalculated data found' for all combinations.

    if it happens only with some plants then you have problem in control query.

    MB

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 04, 2005 at 01:39 PM

    I think the variable issue that Karthik mentions is the most likely cause.

    You must have the box checked in the variable definition for - Can be changed during navigation.

    Without the setting, the cache will only be used if the variable values entered for an execution exactly match the values for the previous execution. So your wide open run with Reporting Agent is not matching what the user has entered when they run the query. Don't think SAP does a very good job explaining how important this setting is.

    There is another possibility if you have mutliple Appl Servers. You either need to cache the results on both appl servers by having Reporting Agent run the query once on each Appl Server or specify Cross Appl Server caching.

    If you want to see what I mean, you can use RSRCACHE to look at what is cached. Go to Main Memory, or one of the other caches you have specified and drill down until to a query, then drill into the query and you should see folders label Hierarchies/ Variables.

    If the Variable setting mentioned earlier is NOT set, you will see the variable and the user entered values for that execution. Once the change is made to the variable, you will no longer see that variable and the user specified values when you come look at the query in RSRCACHE.

    Message was edited by: Pizzaman to add inof on RSRCACHE

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.