Skip to Content

Custom Attribute filled through SQL throws error in UI

Hey Gurus,

Bare with me ...

I have a custom table in my IdM database, this table contains a certain number of usernames.

At certain points in time someone needs to be able to start a task in the IdM UI to create a new identity entry using the first entry of the custom table as a username (mskeyvalue). The tricky part is that when creating the new identity the username needs to be shown to the person doing it.

So what I tried was to create a custom attribute and through Attribute Values, SQL query I made a SELECT TOP 1 from the table. This select worked when I tried it in a test job. I assigned this custom attribute to the MX_PERSON entry type and through it into a task which creates new entries. However when I try to run the task from the IDM UI I get a java.lang.NullPointerException.

Anyone can help me out here?

Thanks in advance.

PS: I'm running IdM 7.2 SP6

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Mar 12, 2013 at 10:15 AM

    Hi Jonathan,

    by pure chance I've read your question. We had similary issue which could be solved by setting the rigth permissions to the table. We gave user mxmc_prov_u select permission.

    Maybe this helps.

    Regards,

    Carsten

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 12, 2013 at 01:26 PM
    Add comment
    10|10000 characters needed characters exceeded

  • Mar 14, 2013 at 07:50 AM

    Hello Carsten & Matt,

    Matt: I had already found that solution on your blog. Apparently the issue went further than that, even though the SQL command worked in a IdM test job it didn't while on the portal. So after some back and forth with some people we figured out the db schema hadn't been set correctly.

    Anyway, this problem is now solved but I'm still faced with the issue that the query returns 2 values instead of one and the first value is an empty field. I can set the Presentation to lookup which apparently ignores the empty value and sets the correct one but I can only do this for custom attributes and not for things like mskeyvalue for example.

    KR,

    Jonathan

    Add comment
    10|10000 characters needed characters exceeded