Skip to Content
avatar image
Former Member

BO 4.0 sp2 and crystal reports 2011 sp2 installed on same machine,facing issue while opening BO client tools?

HI ALL,



please please let me know the solution of above mentioned problem if some one came across the same and  resolved.We are facing the same issue.BO 4.0 sp2 and crystal reports 2011 sp4 on same machine.we are installing it on our ides system.server side it is functioning right but not at the desktop(client tools) its not.
cannot open webi rich client at all it throws "An error occured at session creation" and followed by

com.sap.webi.client.toolkit.exception.WIException: initContainer failed : java.lang.UnsatisfiedLinkError: com.businessobjects.cdz_inproc.client.JniFacade.initContainer(Lcom/businessobjects/cdz_inproc/client/JniContainerInfo;Lcom/businessobjects/cdz_inproc/client/InvocationStatus;)V
at com.sap.webi.client.toolkit.exception.WIExceptionFactory.create(WIExceptionFactory.java:18)
at com.sap.webi.client.toolkit.internal.WebIEngineRCImpl.start(WebIEngineRCImpl.java:105)
at com.sap.webi.client.toolkit.SessionContextManager.startWebiEngine(SessionContextManager.java:206)
at com.sap.webi.client.toolkit.SessionContextManager.createSessionContext(SessionContextManager.java:186)
at com.sap.webi.ui.context.managers.SessionsManager.loginAndGetSessionContext(SessionsManager.java:315)
at com.sap.webi.ui.context.managers.SessionsManager.logOnRepository(SessionsManager.java:221)
at com.sap.webi.ui.context.managers.SessionsManager.initFirstSession(SessionsManager.java:137)

System details
32 bit system
windows 7
microsoft 2010

please guide me as its urgent and i dont know much about the installations,basically i am from BW background.thanks in Advance
please reply as well incase to (suresh82.sap@gmail.com)

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Dec 15, 2012 at 05:54 PM

    Hi Suresh,

    You've mentioned the versions in the description as BI 4.0 SP2 and CR 2011 SP4, however in the title it says CR 2011 SP2. If you have installed BI 4.0 SP2 and CR 2011 SP4, I would suggest you to install CR 2011 SP2 as both need to be on the same patch level.

    Is BI 4.0 server package or client that you've tried to install? If it is a server then I'm afraid Windows 7 is the not the right OS for the server install. Please refer to the PAM guide for BI 4.0 SP02 regarding supported platforms information.


    http://scn.sap.com/docs/DOC-20537

    http://scn.sap.com/docs/DOC-21609

    In R3 version we had issues such as this and needed to follow a specific installation order. However its not as such in R4. Still I would suggest you that once you are on the supported platform, try installing CR 2011 SP2 first then install BI 4.0 SP02 server.

    Else, if you have tried install both BI 4.0 and CR client tools, then check the below SAP note:

    http://service.sap.com/sap/support/notes/1642091


    Regards,

    Shafi

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Suresh,

      Yes, the patch levels should be equal because of compatibility reasons. Since there would be some common files and dlls that would be shared on the same machine which need to compatible with each other.

      Try installing CR2011 SP2 first and then Bi 4.0 SP02 next and verify if it works.

      Please turn off the antivirus (if any) while installing the softwares as the files would be scanned during the installation time. Also when you launch the client tools, it is indeed the corresponding exe's that would be launched which might be checked as well by the antivirus.

      Coming to ports, the communication ports are used to communicate to the server (remote) while you launch the client tools after installation (esp. the CMS,IFRS/OFRS).

      Regards,

      Shafi

  • avatar image
    Former Member
    Mar 17, 2015 at 04:38 AM

    Hi Ramadurgam,

    For me also its showing the error 😔

    I am using BO 4.0 SP4 and Crystal Reports 2011 SP11 and even Java version is 7 update 67. but still unable to open Webi.

    please help .


    Regards,

    Santhosh.S

    Add comment
    10|10000 characters needed characters exceeded