Skip to Content

wily9 doesnt start on Aix 6.1 after successful installation -urgent

Hi Experts,

For Technical Monitoring scenario on SM 7.1 sp05 i have installed wily 9.1.0.2 and also installed java6 saperately to support wily9 run as per the wily9 release note Note 1565954 - Introscope 9 Release Notes.mht.

As per the blog post http://scn.sap.com/message/10228359 did edit the file Introscope_Enterprise_MAnager.lax for parameter

  1. old:

#lax.nl.current.vm=jre/bin/java

  1. my customizing

lax.nl.current.vm=/path/to/java6/bin/java or /usr/java6_64/bin/java

3. Restarted the EM and checked if this works. start up log file shows (' em.log' ) ' 'No Java Virtual Machine can be found from your PATH enviroment variable. You must install a VM prior to run this program'

I tried temporarily setting environment variable from old version of java to new (java6) and changed PATH value also ...however it was of no use.

Did any of you faced such issue, quick reponse is highly appreaciated.

Thanks & Regards,

Rupesh

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    Dec 18, 2012 at 05:40 AM

    Hi There,

    Eventually i followed below sequence to get rid of the issue :

    1. Re-installed Wily9 EM with ./introscope9.1.0.0linuxAMD64SAP.bin –Djava.awt.headless=true

    2. Extracted Management Module in wily9 EM installation directory

    3. Started EM with ./EMCtrl.sh start

    Thats it nothing else (No JVM6 saperately or any parameter adjustment). and the issue with start of EM or restarting it.... is not there now.

    Thanks JRM ....going through the installation guide once more helped.

    Thanks & Regards,

    Rupesh

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 14, 2012 at 11:07 AM

    hi ,

    You must follow the wily installation guide and set up the JVM parameters. the guide here,

    http://service.sap.com/instguides -> Installation & Upgrade Guides -> SAP Components -> SAP Solution Manager -> Release 7.1 -> Installation -> Wily Introscope Setup Guide 9.0

    Page number 25, you can also check the other vm related error we receive in Wily 8 here http://scn.sap.com/docs/DOC-33015

    please check

    Thanks

    Jansi

    Add comment
    10|10000 characters needed characters exceeded

    • Hi JRM,

      Thanks for the reply. I have re-checked the installation guide for page number 25, need a little clarification here - I have installed wily9 Introscope Enterprise Manager and page number 25 talks about settgin jvm parameters for 'wily9 Introscope agent' so did you mean these settings are applicable for both wily9 Introscope Enteprise Manager and wily9 Agent ?? because under EM installtion section jvm settings are not mentioned

      This was the case that is why i created a blog post as installstion guide was in reference while we were performing it.

      Thanks & Regards,

      Rupesh

  • avatar image
    Former Member
    Apr 02, 2013 at 01:52 PM

    Hi,

    I had the same issue with Wily 9.1 installation.

    It is very important to start installation with argument –Djava.awt.headless=true

    ./introscope9.1.0.2aix64SAP.bin -Djava.awt.headless=true

    Now it is working.

    Thanks,

    Regards,

    Add comment
    10|10000 characters needed characters exceeded