Skip to Content
author's profile photo Former Member
Former Member

After upgrade to BW 7.31 SP5 InfoSets that contain InfoCubes do not work

Hello there,

We have just upgraded to BW 7.31 SP5 from 7.02. We have several InfoSets that contain InfoCubes. The problem is that none of the BEx queries written on those InfoSets now work. No Data Available is the message. However, there is data, and if you build a query on InfoCube directly, it works fine.

Did anybody experience the same issue, or knows how to resolve it?

Thanks,

Andrei

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Dec 11, 2012 at 06:11 AM

    Hi,

    Regenerate your Queries in RSRT.

    Goto RSDIPROP t-code -->Set Query Read Mode for your Infoset to "X"

    Try to run the Query once in RSRT and see whether the data comes.....

    Regards,

    suman

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      As a follow-up to this, we recently had the same issue again with an Infoset built on an Infocube that wouldn't display data. Clearing the cache did not work in this case, but I found that running the program SAP_FACTVIEWS_RECREATE in SE38 fixed the issue. Apparently the join on the fact tables of the Infocube had been broken (perhaps by the upgrade but I'm not sure) so recreating the union join resolved the problem.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.