Skip to Content
0
Former Member
Dec 07, 2012 at 10:58 AM

db error when moving 4.5 to new server

36 Views

Hello Ancile,

We are moving our 4.5 PP system to a new server.

We moved the glossary and server (MS sqlsserver 2008R2) databases via backup restore and performed a new installation of the PP software pointing it to the existing databases.

During the vignette install it errors out during the DB upgrade which allows us to continue but causes a version mismatch error during the uperform installation.

Extract form the collaboration install logfile:

(Dec 7, 2012 9:45:54 AM), Install, java.lang.Class, msg1, [## COLLAB INSTALL LOG ##] 07-Dec-2012 09:45:54 INFO (Schema) [com.vignette.tableinstaller.schema.Schema] started: reading schema from D:\uPerform\Vignette\Collaboration\DBSetup\scripts\CreateDatabaseRequiredObjectsMSSQL.xml

(Dec 7, 2012 9:45:54 AM), Install, java.lang.Class, msg1, [## COLLAB INSTALL LOG ##] 07-Dec-2012 09:45:54 INFO (Schema) [com.vignette.tableinstaller.schema.Schema] finished: reading schema from D:\uPerform\Vignette\Collaboration\DBSetup\scripts\CreateDatabaseRequiredObjectsMSSQL.xml

(Dec 7, 2012 9:45:55 AM), Install, java.lang.Class, msg1, [## COLLAB INSTALL LOG ##] 07-Dec-2012 09:45:55 INFO (ConnectionFactory) [com.vignette.tableinstaller.sql.ConnectionFactory] started: connecting to database at jdbc:vignette:sqlserver://<server>:1433;databasename=uPerformServer

(Dec 7, 2012 9:45:55 AM), Install, java.lang.Class, msg1, [## COLLAB INSTALL LOG ##] 07-Dec-2012 09:45:55 INFO (ConnectionFactory) [com.vignette.tableinstaller.sql.ConnectionFactory] finished: connecting to database at jdbc:vignette:sqlserver://<server>:1433;databasename=uPerformServer

(Dec 7, 2012 9:45:55 AM), Install, java.lang.Class, msg1, [## COLLAB INSTALL LOG ##] 07-Dec-2012 09:45:55 INFO (ConnectProps) [com.vignette.tableinstaller.ConnectProps] started: reading schema version

(Dec 7, 2012 9:45:55 AM), Install, java.lang.Class, err, [## COLLAB INSTALL LOG ##] 07-Dec-2012 09:45:55 ERROR (ConnectProps) [com.vignette.tableinstaller.ConnectProps] FAILED: reading schema version


EXCEPTION: java.sql.SQLException
MSG: Datastore does not appear to contain Portal or Builder or Collaboration tables.

Did we forget something when moving the databases?

What causes this error?

We tried using different SQL accounts but it does not look like a permissions problem.

Sander

Attachments

error2.png (21.9 kB)
error.png (14.6 kB)