Skip to Content
Former Member
Nov 27, 2012 at 07:57 AM

Enhanced interface determination - two step message mapping - Split mapping created no messages


Hello expert,

I use enhanced interface determination in ID for a 1:4 message split mapping, the interface mapping contains two step message mapping, and when test end-to-end,

it will fails at the interface mapping with "Split mapping created no messages". but when it's a one step message mapping, I have no problem with it. Can anyone give an insight on this? below is the details of my scenario:

1: Sender agreement:

File adapter will reads in a plain text file, and converts it into a simple XML file.

2. Receiver detemination.

3. interface detemination:

An interface mapping is used to split the source file into 1-4 message interface and send them to different places.

two step message mapping:

Step 1 message mapping: some cross value mapping using xref table in PI system.

Step 2 message mapping: a 1-4 message splitted mapping, this will split the source XML into 1 to 4 messages base on some condition.

3. Receiver agreement.

I have read many posts in SCN, like But my source XML does not contains the namespace "" mentioned by lots of the post. and I tried to add a XLST mapping before the 1:4 message mapping start. All these do not solved my problem.

When I use one step message mapping, the end-to-end test will success, but using one step message mapping will complicated the logic of the graphic mapping.

I wonder if there is any difference between one-step and two-step mapping in interface mapping that caused the error? How could I solve this issue?

can you please help? thank you!

The detail error:

- < SAP:Error xmlns:SAP =" " xmlns:SOAP =" " SOAP:mustUnderstand =" " >

< SAP:Category > XIServer </ SAP:Category >

< SAP:Code area =" MAPPING " > GENERIC </ SAP:Code >

< SAP:P1 > Split mapping created no messages </ SAP:P1 >

< SAP:P2 />

< SAP:P3 />

< SAP:P4 />

< SAP:AdditionalText />

< SAP:ApplicationFaultMessage namespace =" " />

< SAP:Stack > Split mapping created no messages </ SAP:Stack >

< SAP:Retry > M </ SAP:Retry > </ SAP:Error >