/scripts/ahub.form.attachments.js
2

SAP HANA XS Advanced 2.0 - "Failed to resolve reference for provided property"

Jan 05, 2017 at 02:18 AM

699

avatar image
Former Member

Dear experts,

I did the "tinyworld" example from the XSA Developer Guide. I'm stuck at the point where the HTML5 page should output oData provided data. All steps before worked. I also pulled the GITHub source to make sure I made no mistake with the same error. I refer to pages 37-38 in the Guide.

Error message when running the UI as a Web Application is:

{"message":"Failed to resolve reference for provided property: 4adc2083-699c-4a77-8074-1bdbe59c8257-eow0on9bphymhtzt-tinyworld#tinyjs_api#service_url"}

Now I have no idea anymore what I should check - I somehow thing this could be rather a setup issue than a source code problem?

Gunter

10 |10000 characters needed characters left characters exceeded

Hi Gunter,

js-server started at first?

Maybe you missed the MTA entry:

provides: - name: tinyjs_api properties: service_url: ${default-url}

Good luck!

0
* Please Login or Register to Answer, Follow or Comment.

5 Answers

avatar image
Former Member Dec 26, 2017 at 06:03 PM
1

In my case I had to start the tinyjs application. After that, the tinyui application was able to start.

Share
10 |10000 characters needed characters left characters exceeded
Dirk Raschke Jan 05, 2017 at 01:43 PM
0

And I found this videos from the HANA Academy helpful:

https://youtu.be/3R_uaJp20OQ?list=PLkzo92owKnVwL3AWaWVbFVrfErKkMY02a&t=101

Maybe it helps you to.:)

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

I did not see any relationship between the question and the answer.

0
Susumu Honna
Feb 22, 2017 at 02:42 AM
0

I had encountered same issue in HANA2.0 and found the solution. I think the development guide is old so that it is written based HANA1.0 SP11. With HANA2.0, XSA change the Port-based routing from host-based routing, so you need to map the port between tinyui and tinyjs application using following command.

1. Check the currently XSA route information.

# xs routes

2. Mapping the route between tinyui and tinyjs port.

# xs map-route <your tinyjs app name> -p <your tinyui port#>

3. Access the tinyui application (~/index.html), tinyui application may work fine.

* In case of my environment, tinyui worked fine to unmap route after step 3. I think routing function has still some bug.

Please refer the following link in detail.

https://blogs.sap.com/2016/12/01/sap-hana-2.0-sps-0-new-developer-features/

http://help-legacy.sap.com/saphelp_hanaplatform/helpdata/en/7b/24c9d9284643e49554e2eeeaad7be7/content.htm

BR,

Susumu

Share
10 |10000 characters needed characters left characters exceeded
Stefan Porges Mar 10 at 03:05 PM
0

Hi,

was anyone able to solve this problem? I'm running in the same error (Hana Express 2.0). Tried also the provided xs map-route hint, but this does not fix the problem for me.

Can anyone help, thanks in advance

Stefan

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member
Mar 15 at 05:04 PM
0

Replacing url: ~{service_url} with url: '~{url}' in mta.yaml file (ui module, dependency section) solved the issue

Share
10 |10000 characters needed characters left characters exceeded
Skip to Content