Skip to Content
author's profile photo Former Member
Former Member

ISQL login error SYBASE

Hi Guys,

We recently installed SAP NW7.3 Ehp1 on Windows 2008 server with Sybase database version 15.7,installation was successful without any error's,when I try to login to database its throw error

I logged in as SIDADm and exeuted below command and end up with below error,

D:\sybase\SBP\OCS-15_0\bin>isql

Password:

CT-LIBRARY error:

ct_connect(): directory service layer: internal directory control layer

error: Requested server name not found.

Could any one help me out with how this can be fixed?

Regards

Uday

Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Nov 20, 2012 at 07:39 AM

    Check what %DSQUERY% is set to.

    Try ruunning isql -Usa -S DSQUERY

    Where DSQUERY is the name of the ASE instance as defined in sql.ini

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 20, 2012 at 08:10 AM

    with witch user you are loged on?

    To run isql command use syb<sid> user.

    Please check the environment of the users:

    LIB=<Win-drive>:\sybase\SID\OCS-15_0\lib;

    PATH=<Win-drive>:\sybase\<SID>\ASE-15_0\jobscheduler\bin;<Win-drive>:\sybase\<SID>\ASE-15_0\dll;<Win-drive>:\sybase\<SID>\ASE-15_0\bin;<Win-drive>:\sybase\<SID>\DBISQL\bin;<Win-drive>:\sybase\<SID>\OCS-15_0\lib3p64;<Win-drive>:\sybase\<SID>\OCS-15_0\lib3p;<Win-drive>:\sybase\<SID>\OCS-15_0\dll;<Win-drive>:\sybase\<SID>\OCS-15_0\bin

    SYBASE=<Win-drive>:\sybase\<SID>

    SYBASE_ASE=ASE-15_0

    Regards Arne

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Mar 03, 2014 at 04:22 PM

    Hi Uday,

    I think that your original problem could be that you were not using encryption.

    I would try launching ISQL with the -X option "Initiates the login connection to the server with

    client-side password encryption. "

    Something like:

    isql -Usa -Ppassword -X


    Regards,

    Andreu

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 26, 2014 at 07:09 AM

    Hi,

    I am trying to connect to the ASE server using Command Line. I have logged in with the lroot user. I am running the following command : isql -S <server_name> -U sa -P <pwd>

    In this case, what will be my SID?

    Regards,

    Anmol Goel

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Anmol,

      Are you using SAP applications ? ( you are talking about IQ, maybe, Business Warehouse ? )
      I'm not sure to understand your environment and what you are trying to do.
      Outside SAP Applications the command line used to connect to an IQ server (dbisql) is different of the one for ASE (isql). But it would be better to understand first which is your architecture/environment.
      Please open another discussion anyway 😉

      Best regards,
      Victoria Normand.

  • Posted on May 08, 2015 at 06:46 AM

    Hi Uday,

    Kindly check the following:

    1) Whether the server is Up or not.

    2) If up then check whether Environment variable is set or not.

    3) Check the interfaces file for the server. See if it entry is there.

    Hope this helps.

    Thanks & Regards,

    Amit kumar Singh

    Message was edited by: AMIT KUMAR SINGH

    Add a comment
    10|10000 characters needed characters exceeded

    • Hello Federico,

      This thread is now quite old and the initial question was already answered, even if unfortunately no correct answer was marked.

      Basically the problem was because

      1) SYBASE env variables were not set for the OS user used. To avoid this, it was suggetsed to use the syb<SID> user.

      2) sa login is locked by default in a Business Suite environment.Login sapsa should be used instead

      3) Network password encryption is enabled in a Business Suite environment, hence you have to use the option -X when using isql.

      Just to clarify, in a Business Suite environment you cannot have more than one "instance" or SID in an ASE dataserver (but it could be possible with MS Sql Server for example).

      Regards,

      Cris

  • Posted on Dec 10, 2014 at 05:45 PM
    -1

    Hi,

    It says it can't find your server name

    You can isql these two ways.
    isql -Uusername -Sservername_in_the_sql.ini_file

    or
    isql -Uusername -Sipaddress_of_box_ase_resides_on:portnumber

    Thanks,
    Dawn


    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.