Skip to Content
0
Nov 19, 2012 at 08:16 AM

switch sapjvm 4.1 - double stack Solution Manager Java instance fails

61 Views

Hi there.

We got a now a problem after swich from IBM 1.4. ( j9vm23) to the sapjvm 4.1.

Last week the instance runs not so properly, on friday i added in the configtool the parameters

from sapnote 1603093. After system reboot: The

Error message : Dispatcher running but no server connected !

Today we got a MAX Attention/EGI SAP Service session and the Java instance wont come up!

Very nice.

  1. checked JAVA_HOME= echo $JAVA_HOME

/usr/sap/SOL/SYS/exe/jvm/linuxx86_64/sapjvm_4.1.024/sapjvm_4 =OK!

2. check of java -version

java version "1.4.2_34"

Java(TM) 2 Runtime Environment, Standard Edition (build 4.1.024)

SAP Java Server VM (build 4.1.024 21.1-b02, Aug 13 2012 15:09:20 - 41_REL - optU

OUTPUT of std_server0.out=

--------------------------------------------------------------------------------

stdout/stderr redirect

--------------------------------------------------------------------------------

node name : server0

pid : 21353

system name : SOL

system nr. : 66

started at : Mon Nov 19 08:44:09 2012

[Thr 47202885195296] MtxInit: 10001 0 2

(CompilerOracle read from file /usr/sap/SOL/DVEBMGS66/exe/sapjvm_4/jre/.hotspot_compiler)

JVM Directory = /usr/sap/SOL/DVEBMGS66/exe/sapjvm_4/jre

SAP J2EE Engine Version 7.01 PatchLevel 129909. is starting...

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Introscope Agent Release 8.2.4.0 (Build 476771)

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Using Java VM version "SAP Java Server VM 1.4.2_34" from SAP AG

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Trying to load agent profile based on system property "com.wily.introscope.agentProfile"

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Unable to load agent profile because the system property could not be found

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Trying to load agent profile from resource from the class path based on system property "com.wily.introscope.agentResource"

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Unable to load agent profile because the system property could not be found

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Trying to load agent profile based on the working directory at: /usr/sap/SOL/DVEBMGS66/j2ee/cluster/server0/wily/IntroscopeAgent.profil

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Unable to load agent profile because of: java.io.FileNotFoundException /usr/sap/SOL/DVEBMGS66/j2ee/cluster/server0/wily/IntroscopeAgent

11/19/12 08:44:11 AM CET [WARN] [IntroscopeAgent] No Agent profile found. Using system defaults for Introscope Enterprise Manager communication.

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Agent Metric Aging is turned off

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Agent Metric Aging: property introscope.agent.metricAging.heartbeatInterval is set to 1800

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Agent Metric Aging: property introscope.agent.metricAging.dataChunk is set to 500

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Agent Metric Aging: property introscope.agent.metricAging.numberTimeslices is set to 3000

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Looking for agent profile property "introscope.agent.extensions.directory" to locate the extensions directory.

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] The agent extension property "introscope.agent.extensions.directory" is not set. No extensions will be loaded.

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Introscope Agent startup complete.###

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] The Agent will attempt to determine its name.

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Unable to determine the Agent name from the System Property "com.wily.introscope.agent.agentName" because that property was either not

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Unable to determine the Agent name from a user specified System Property because the property "introscope.agent.agentNameSystemProperty

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] The Agent will not attempt to automatically determine its name from the Application Server because that feature has been disabled in th

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Unable to determine the Agent name from the "introscope.agent.agentName" property in the Introscope Agent Profile because it was either

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Using the unnamed Agent name "UnnamedAgent".

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Initial agent name set to UnnamedAgent

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent.Isengard] Initiating connection attempts to the Introscope Enterprise Manager.

11/19/12 08:44:11 AM CET [WARN] [IntroscopeAgent] No bytecode transformers are configured. Please make sure ProbeBuilder is deployed as an Agent extension.

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent.Isengard] The Agent reconnection delay is set to 15 second(s).

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Started Error Reporting service

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Stall event service: stall threshold of 30 seconds

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Stall event service: resolution of 10 seconds

11/19/12 08:44:11 AM CET [INFO] [IntroscopeAgent] Started Stall Service

11/19/12 08:44:11 AM CET [WARN] [IntroscopeAgent.ConnectionThread] Failed to connect to the Introscope Enterprise Manager at localhost:5001,com.wily.isengard.postofficehub.link.net.Defa

Loading: LogManager ... 1097 ms.

Loading: LogManager ... 1097 ms.

Loading: PoolManager ... 9 ms.

Loading: ApplicationThreadManager ... 4.745: [GC 4.745: [ParNew: 409600K->2974K(512000K), 0.0188700 secs] 409600K->2974K(946176K), 0.0189620 secs] [Ti

6756 ms.

Loading: ThreadManager ... 18 ms.

Loading: IpVerificationManager ... 21 ms.

Loading: ClassLoaderManager ... 43 ms.

Loading: ClusterManager ... 551 ms.

Loading: LockingManager ... 11/19/12 08:44:21 AM CET [WARN] [IntroscopeAgent.ConnectionThread] Failed to connect to the Introscope Enterprise Manager

108 ms.

Loading: ConfigurationManager ... 2019 ms.

Loading: LicensingManager ... 408 ms.

Loading: CacheManager ... 344 ms.

Loading: ServiceManager ...

Loading services.:

Service memory started. (70 ms).

Service runtimeinfo started. (77 ms).

Service cross started. (98 ms).

Service timeout started. (38 ms).

Service trex.service started. (189 ms).

Service p4 started. (537 ms).

Service classpath_resolver started. (81 ms).

Service userstore started. (172 ms).

Service jmx_notification started. (78 ms).

service deploy ================= ERROR =================

Core service deploy failed. J2EE Engine cannot be started.


java.lang.ExceptionInInitializerError

#at com.sap.engine.services.deploy.server.DeployServiceFactory.newDeployService(DeployServiceFactory.java:23)

#at com.sap.engine.services.deploy.server.DeployServiceFrame.start(DeployServiceFrame.java:59)

#at com.sap.engine.core.service630.container.ServiceRunner.startApplicationServiceFrame(ServiceRunner.java:214)

#at com.sap.engine.core.service630.container.ServiceRunner.run(ServiceRunner.java:144)

#at com.sap.engine.frame.core.thread.Task.run(Task.java:64)

#at com.sap.engine.core.thread.impl5.SingleThread.execute(SingleThread.java:83)

#at com.sap.engine.core.thread.impl5.SingleThread.run(SingleThread.java:156)

Caused by: org.omg.CORBA.INITIALIZE: cannot instantiate com.sap.engine.system.PorrtableRemoteObjectProxy vmcid: 0x0 minor code: 0 completed: No

#at javax.rmi.PortableRemoteObject.createDelegateIfSpecified(PortableRemoteObject.java:181)

#at javax.rmi.PortableRemoteObject.<clinit>(PortableRemoteObject.java:58)

#... 7 more

java.lang.ExceptionInInitializerError

#at com.sap.engine.services.deploy.server.DeployServiceFactory.newDeployService(DeployServiceFactory.java:23)

#at com.sap.engine.services.deploy.server.DeployServiceFrame.start(DeployServiceFrame.java:59)

java.lang.ExceptionInInitializerError

#at com.sap.engine.services.deploy.server.DeployServiceFactory.newDeployService(DeployServiceFactory.java:23)

#at com.sap.engine.services.deploy.server.DeployServiceFrame.start(DeployServiceFrame.java:59)

#at com.sap.engine.core.service630.container.ServiceRunner.startApplicationServiceFrame(ServiceRunner.java:214)

#at com.sap.engine.core.service630.container.ServiceRunner.run(ServiceRunner.java:144)

#at com.sap.engine.frame.core.thread.Task.run(Task.java:64)

#at com.sap.engine.core.thread.impl5.SingleThread.execute(SingleThread.java:83)

#at com.sap.engine.core.thread.impl5.SingleThread.run(SingleThread.java:156)

Caused by: org.omg.CORBA.INITIALIZE: cannot instantiate com.sap.engine.system.PorrtableRemoteObjectProxy vmcid: 0x0 minor code: 0 completed: No

#at javax.rmi.PortableRemoteObject.createDelegateIfSpecified(PortableRemoteObject.java:181)

#at javax.rmi.PortableRemoteObject.<clinit>(PortableRemoteObject.java:58)

#... 7 more

java.lang.ExceptionInInitializerError

#at com.sap.engine.services.deploy.server.DeployServiceFactory.newDeployService(DeployServiceFactory.java:23)

#at com.sap.engine.services.deploy.server.DeployServiceFrame.start(DeployServiceFrame.java:59)

#at com.sap.engine.core.service630.container.ServiceRunner.startApplicationServiceFrame(ServiceRunner.java:214)

#at com.sap.engine.core.service630.container.ServiceRunner.run(ServiceRunner.java:144)

#at com.sap.engine.frame.core.thread.Task.run(Task.java:64)

#at com.sap.engine.core.thread.impl5.SingleThread.execute(SingleThread.java:83)

#at com.sap.engine.core.thread.impl5.SingleThread.run(SingleThread.java:156)

Caused by: org.omg.CORBA.INITIALIZE: cannot instantiate com.sap.engine.system.PorrtableRemoteObjectProxy vmcid: 0x0 minor code: 0 completed: No

#at javax.rmi.PortableRemoteObject.createDelegateIfSpecified(PortableRemoteObject.java:181)

#at javax.rmi.PortableRemoteObject.<clinit>(PortableRemoteObject.java:58)

#... 7 more

[Framework -> criticalShutdown] Core service deploy failed. J2EE Engine cannot be started.

Nov 19, 2012 8:44:30 AM com.sap.engine.core.Framework [SAPEngine_System_Thread[impl:5]_61] Fatal: Critical shutdown was invoked. Reason is: Core service deploy failed. J2EE

Heap

par new generation reserved 614400K, committed 614400K, used 410846K [0x0000000040fe0000, 0x00000000667e0000, 0x00000000667e0000)

eden space 409600K, 99% used [0x0000000040fe0000, 0x0000000059e301f8, 0x0000000059fe0000)

from space 102400K, 2% used [0x00000000603e0000, 0x00000000606c78c0, 0x00000000667e0000)

to space 102400K, 0% used [0x0000000059fe0000, 0x0000000059fe0000, 0x00000000603e0000)

concurrent mark-sweep generation reserved 434176K, committed 434176K, used 0K [0x00000000667e0000, 0x0000000080fe0000, 0x0000000080fe0000)

concurrent-mark-sweep perm gen reserved 524288K, committed 524288K, used 25360K [0x0000000080fe0000, 0x00000000a0fe0000, 0x00000000a0fe0000)

--------------------------------------------------------------------------------

stdout/stderr redirect

--------------------------------------------------------------------------------

node name : server0

pid : 21353

system name : SOL

system nr. : 66

started at : Mon Nov 19 08:44:50 2012

[Thr 47804886816288] MtxInit: 10001 0 2

(CompilerOracle read from file /usr/sap/SOL/DVEBMGS66/exe/sapjvm_4/jre/.hotspot_compiler)

JVM Directory = /usr/sap/SOL/DVEBMGS66/exe/sapjvm_4/jre

Please give me a advice, we extended the max heap from 2048 to 3096MB, no success for the start process!

Thx ralph

Attachments