Skip to Content
avatar image
Former Member

KEPM - Local variable for Report Layout

Dear All,

I am planning to use local variable for the Period in COPA
Planning layout, which should pick dynamically period from Initial screen as
January to December of XXXX year. So each column for Sales Quantity I have
provided San, San1, San2 and so on for the Period/year, which should pick
January to December 2013 , since in the initial screen period/Year provided as
001.2013 to 012.2013, but I was getting the following message, please help me
resolve this error.

Planning package cannot be edited with planning layout SOP

  1. Message no. KG1003

Diagnosis

Planning layout "SOP" has one or more variables for characteristic
"PERIO". These variables are given values from the selection
criterion for the planning package. The selection criterion (single values
and/or interval) must match the variables.

System Response

The system tries to replace the variables in the planning layout with the selection
criterion for the planning package.If, for example, there is a variable for a
single value in the planning layout for a characteristic, then the selection
criterion must contain a single value. If there are two variables for the from
and to value of an interval in the planning layout for a characteristic, then
an interval must also exist in the selection criterion .

Procedure

Change planning la yout "SOP" or use a different planning layout.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Nov 14, 2012 at 01:13 PM

    Hi,

    This means that  in "SOP" planning layout you have more Charataristics than the planning package , Kindly check  in Transaction Code KE15 / KE16  In KE16, go to Edit -> Gen. data selection -> Gen data selection and you can see the selected characteristics.  In KEPM, when you expand the Planning Level (by clicking on the triangle adjacent to the planning level), you see planning package.  Right-click on planning package and choose change planning package.  On the right window, you will see the characteristics in the planning package.  Kindly check whether characteristics "PERIO" exists there or not.  I think it is not there

    When you double-click on the planning package, you will see the planning method in the left bottom window pane.  Under the planning method, expand by clicking on the twisty adjacent to 'Enter planning data'.  You will see a parameter set with the same name as your planning level/package.  Right-click on that and choose change parameter set.  On the right window, you will be able to choose a layout (or even create one - it will basically take you to KE14).

    Regards

    Diptadhi

    Add comment
    10|10000 characters needed characters exceeded