Skip to Content
author's profile photo Former Member
Former Member

Encoding issue and message failing in Integration Engine

Hi Experts,

We are facing an issue with encoding in file to file scenario.

We receive xml files from SAP BI 7.3 system in ANSI format(i am checking the same using Notepad++).

The xml encoding is UTF-16 (<?xml version="1.0" encoding="UTF-16"?>)

The sender channel "FiIe Type" is set to "Binary"

The xml files get picked up from the sender directory and fails in the Integration Engine using the following error:

<SAP:Stack>Runtime exception occurred during application mapping com/sap/xi/tf/_MM_SAPFinance_BW_2_Clarity_; com.sap.aii.utilxi.misc.api.BaseRuntimeException:Content is not allowed in prolog.</SAP:Stack>

But when i change the file manually to "Unicode" (By using "Save As" option in windows notepad --> Encoding "Unicode"

) in my local system and upload the same file to the source directory. Then the message gets successfully processed.

Please let me know if anyone have faced this issue and the fix.

Thanks,

Sudhansu

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on Nov 12, 2012 at 09:52 PM

    When the SAP BI systems stores a file in the file system and you notice that the encoding is not identical to the XML encoding declaratin, then you have to fix this in the SAP BI system.

    If the file is downloaded by a standard report, check if there is an setting for this, otherwise create a ticket for SAP.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 13, 2012 at 12:23 PM

    Hi Sudhansu,

    It sounds like you are getting files with the BOM (byte order mark) in the prolog of the file. The easiest way to solve this is to make sure from the sender side these bytes do not exist in the file. Otherwise you might have to play around with conversions of the file encoding or writing code for a java mapping or adapter module to remove them.

    Regards,

    Ryan Crosby

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.