Skip to Content
avatar image
Former Member

reg: Depreciation posting(AFAB)

Hi Friends,

when the user had run  the AFAB Tcode (for 9th period, 2012, company code ABCD ) in test run mode with session name(ABCD) by checking the keep session checkbox, there was some data in Production system.

Then user unchecked the test run and executed the AFAB in background. A batch job was created. when he run that job in SM35 he got the first error as period was not open and then he opened the period and again he run the batch job he got the second error saying that Fi to Co posting was locked and then he removed the lock and again run the batch job and third time he got the message asking for the posting key and the user got confused and came out that screen and deleted the batch job.

Again he run the AFAB Tcode (for 9th period, 2012, company code ABCD ) in test run mode with session name(SDFG) by checking the keep session checkbox, there was no data this time.

the user wants that data now.

Could you pl explain me the process, how it can be resolved.

Thanks,

HK

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • avatar image
    Former Member
    Nov 10, 2012 at 05:57 AM

    Hi Friends,

    when the user had run  the AFAB Tcode (for 9th period, 2012, company code ABCD ) in test run mode with session name(ABCD) by checking the keep session checkbox, there was some data in Production system.

    Then user unchecked the test run and executed the AFAB in background. A batch job was created. when he run that job in SM35 he got the first error as period was not open and then he opened the period and again he run the batch job he got the second error saying that Fi to Co posting was locked and then he removed the lock and again run the batch job and third time he got the message asking for the posting key and the user got confused and came out that screen and deleted the batch job.

    Again he run the AFAB Tcode (for 9th period, 2012, company code ABCD ) in test run mode with session name(SDFG) by checking the keep session checkbox, there was no data this time.

    the user wants that data now.

    Could you pl explain me the process, how it can be resolved.

    Thanks,

    HK

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 10, 2012 at 09:50 AM

    Hi,

        In AFAB do the Repeat run for Depreciation for period 9

    Regards

    Diptadhi

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Diptadhi,

      actually i checked in production system.

      After user ran the AFAB batch job for period 9, depreciation was posted,

      ANLP table was updated  for period 9

      but the documents were not posted, i mean AF documents were not generated.

      i checked in the asset values in asset explorer (AW01N), depreciation was posted.

      But FI documents of document type AF were not generated.

      even i checked in the quality system. I am facing the same problem.

      Pl let me know in this regard.

      Thanks,

      HK

  • avatar image
    Former Member
    Nov 10, 2012 at 05:46 PM

    Hi,

    1 ) Please check your settings in OADB whether your book depreciation area is postable to GL, i.e. there should be 1 selected as it indicates Postings to GL in realtime.

    2 ) If you have information for already completed depreciation run then please go to T.code AFBP there enter your relevant info and execute, this will give you complete details. AFBP is relaible than any other log detail reports.

    3 ) Have you maintained the depreciation & accumulated depreciation account in T.code AO90 ?

    Please check all these settings and analyze the issue, AFBP will guide you.

    Regards

    Diptadhi


    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Diptadi,

      I thought that i am also facing the same problem till yesterday in quality system what the client is facing in Production system, but today when i logged into the quality system, i had seen the Batch job created in the SM35.

      when today i logged into quality system, where i am trying to do the AFAB posting, i had seen the Batch session in SM35. and i run that batch job and successfully all the AF documents were posted.

      Now i am in a confusion, what should i suggest to the client, where she had done the AFAB run in Production system but the depreciation is posted in AW01N Tcode and even table ANLP is also updated, but the AF Documents were not posted, which i already mentioned in the earlier mail.

      you mentioned about AFBP Tcode, Pl let me know what is the purpose of this Tcode,

      anyway i executed the AFBP Tcode and given company code ABDC, FIscal year 2012,posting period 09,posting run as 1 and didnot checked List Assets in the production system, then i executed it in the foreground, A total of 66 posting documents were logged in the list.

      But one thing i didnot understand, what is the purpose of this Tcode. Pl give me the clear understanding of this TCODE AFBP. And also let me know how the production issue can be resolved

      Pl tel me how this can be  handled in the production system.

      Am totally in confusion, Pl guide me.

      Thanks,

      HK

  • avatar image
    Former Member
    Nov 11, 2012 at 08:09 AM

    Hi,

       Kindly tell your Client to run the depreciation again in AFAB for period 9 , it will generate your AF document & AW01N will be re-updated.

    Regards

    Diptadhi

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Diptadhi,

      you mean you want me to tell the client to run the depreciation again in AFAB for period 9 with Repeat Run radio button selected instead of planned posting run in production system.

      Pl let me know.

      Thanks,

      Hk

  • avatar image
    Former Member
    Nov 11, 2012 at 08:41 AM

    Hi,

       Tell your client to do planned posting run in for Period 9 in AFAB in Background Processing, It will solve your issue

    Regards

    Diptadhi

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Diptadhi,

      the client already run the AFAB for period 9 in planned posting run in test mode. but they didnot find any data.

      do you want me to suggest the client to run AFAB for period 9 in planned posting run again or do you want me to suggest to run it in repeat run.

      I am sorry am still in confusion about it. Pl donot think wrong.

      Pl confirm me once again as the activity is to be going to happen in production system.

      Thanks,

      HK

  • avatar image
    Former Member
    Nov 11, 2012 at 11:43 AM

    Hi,

       If your client do not see any data in planned posting run for period "9", then tell your client to do the Repeat run for period 9 in Background Processing , select your output device & ticking on "Immediately" button.

       Then check the job in System-Services-Jobs-Jobs Overview. A spool request will be generated against the particular job. There you will find the Depreciation posted entries

       It will solve your issue. Depreciation document will get posted & AW01N will get re-updated

    Regards

    Diptadhi

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi ,

      is there any chance to reverse or delete the asset values which were updated in asset explorer(AW01N) and even the table ANLP for period 9 because the AF Accounting document were not generated.

      and then can i suggest her to run AFAB for the same period 9.

      this is just my idea.

      can we do that if so could you pl guide me how it can be done.

      deletion of tables should be done by basis or is there any other process which can be executed by FI.

      Pl lt me know.

      Thanks,

      HK