Skip to Content
avatar image
Former Member

Problema de Conexion al SAP desde el iPad

Compañeros buen dia,

Promero que todo espero que todos esten bien, resulta que estoy en el proyecto de salir en vivo en sap BO sobre 8.82 PL 07, estoy tratando de conectar el iPad y l iPhone al sap, de antemano les describire lo que tengo ya instalado,

1. La suite de integration Solution completamente configurada

Pero al momento de conectarme por mi ip publica y el puerto 8080 y realiar todas las configuraciones en el ipad y en el usuario del sap como usuario movil y configurandole el telefono y la mac me sale al mometno de conectarme con el iPad el siguiente error,

Fallo el procesamiento

Error interno del servidor. pongase en contacto con el administrador del sistema

De antemano le agradeceria,

Gracias,

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Nov 07, 2012 at 11:52 PM

    Hola Jorge, Puedes revisar la nota de SAP 1602674

    Para la parte de errores internos hay varias causas, te cito parte de la Nota.

    Error: "Connection Failed - The request timed out. (-1001)", “Processing Failed - Internal server error; contact your system administrator”

    Please Verify the connection between the mobile and B1i server. (See SAP Note 1776825)

    The most common issue is the SSL configuration. Note: For the mobile solution, B1i uses default port 8443 with SSL connection. Hence set the mobile app configure under Web Service to <server_ip_address>:8443 and leave SSL ‘ON’ as default.

    Other reasons could be:

    • Root cause 11:  In Integration Framework -> SLD->B1iServer, mobile and target company are not correctly configured.
    • Solution 11:  Choose the target company, Click the button “Test connection” for B1DI and JDBC, ensure the message is successful. Also SLD->WSforMobile->associatedSrvIP, it is configured correctly for the target company (servername/databasename for 8.81PL05 or lower versions, servername for higher versions). 
    • Root Cause 12: Some or all mobile scenarios are not activated correctly.
    • Solution 12 :
      1. Open integration framework web page, choose Scenarios -> Setup. For 1.5.0, it should be “91 of 91”, which means there are totally 91 steps and all of them are activated. If it looks like something like “76 of 91”, it means there are inactive steps.
      2. Choose the “Deactivate” button to deactivate the mobile package. After this, the button changes to “Activate”.
      3. Choose the “Steps” button, a web page would pop up.
      4. Choose the “all Activate” and then click the save button. After that, close this popup.
      5. After a few seconds, the Scenario Steps should become something like “91 of 91”.
      6. Choose the “Activate” button to activate the mobile package. It should pop up a confirmation dialog box, choose the "OK" button. 
    • Root Cause 13: The B1i DI Proxy services (SAP Business One DI Proxy Service and SAP Business One DI Proxy Service Monitor) are not started. (The symptom is mobile app does not respond and there is no pop-up.)
    • Solution 13: Start B1i DI Proxy related services. 
    • Root Cause 14: Integration Framework->SLD->WSforMobile->associatedSrvIP, it is inconsistent with the other server settings. (some are server name, some are IP address)
    • Solution 14: It should be consistent with the other server setting: all using server name, or all using IP address. 
    • Root cause 15: The password has unsupported characters such as “&”, “<” and “>”.
    • Solution 15: avoid to use such characters for mobile users currently. 
    • Root Cause 16: B1i SQL database disk is full.
    • Solution 16: Shrink B1i database or delete the B1i database logs. 
    • Root Cause 17: The default port 1433 is not used by the selected database instance.
    • Solution 17 The TCP IP port of the SQL database instance should be changed to 1433.

    Nos comentas.

    Saludos.

    Alessandro.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Alessandro Lopez Santinelli

      Buenas Tardes,  Gracias Ingeniero Alessandro Lopez, me funciono re bien despues que hice lo que indica aqui en el foro.,  que tenga un buen dia.,

      Slds.

      Victor Ruiz

      Guatemala

  • avatar image
    Former Member
    Feb 03, 2015 at 08:53 PM

    Buenas Tarses Señores.

    En la version 1.11.1 ya no se permite conexion al sistema con certificados no emitidos por entes certificadores. En ese caso hay alguno que haya podido configurarlo sin SSL?

    Saludos Cordiales

    Juan Peña

    Add comment
    10|10000 characters needed characters exceeded