Skip to Content
author's profile photo Former Member
Former Member

Facing a problem in Mail to Proxy scenario...

Hi Experts,

We are facing an issue in Mail to Proxy interface as below.

Issue:

Please find the below error.

Before going to look into the issue I just want to share few of the details regarding this interface.

1. This interface is working fine in QA environment and Pre-Prod but not in DEV.

2. We have tested the same file in DEV earlier it was processed successfully but not now, so we assumed that there is no issue with the file.

3. Just to notify that, also we have done the delta cache refresh as we assumed that there could be a cache issue...but no result.

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

-

Request Message Mapping

-->

-

xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/">

<SAP:Category>Application</SAP:Category>

<SAP:Code area="MAPPING">EXCEPTION_DURING_EXECUTE</SAP:Code>

<SAP:P1>com/sap/xi/tf/_ABC_to_Interface_Report_</SAP:P1>

<SAP:P2>com.sap.aii.utilxi.misc.api.BaseRuntimeException:</SAP:P2>

<SAP:P3>Premature end of file.</SAP:P3>

<SAP:P4 />

<SAP:AdditionalText />

<SAP:Stack>Runtime exception occurred during application mapping com/sap/xi/tf/;

com.sap.aii.utilxi.misc.api.BaseRuntimeException:Premature end of file

<SAP:Retry>M</SAP:Retry>

</SAP:Error>

Since it is a high priority support issue, could you please send your valuable inputs ASAP.

Please let me know if you need any other information regarding the issue.

Best Regards,

Srihari.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on Nov 07, 2012 at 03:45 PM

    Hi Srihari,

    Check if your XML payload in moni is complete . this might be due to processing of incomplete data in which you are trying to process.

    Regards,

    Chichili.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 07, 2012 at 11:03 AM

    Hi Srihari,

    How are you testing this issue in your DEV environment?

    I suspect some issue on your sender side, while sending data to PI. I would suggest to compare the sender XMLs on both DEV and TEST systems and check if there is any discrepancy.

    Any more piece of info is welcome from your side.

    Best Luck,

    V J

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 21, 2012 at 01:50 AM

    Hi Guys,

    Thanks for your valuable inputs.

    Problem got solved.

    Issue due to in communication channel a check box called keep mail attachments has disabled.

    With out our notice it was happened. By enabling it issue got resolved.

    Now we can able to pick the mail attachments.

    Regards,

    Srihari

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.