Skip to Content
0
Former Member
Jul 22, 2005 at 11:17 AM

SSO using sap logon ticket (Lotus Domino)

103 Views

Hi all,

We are facing a problem while using SSO via SAP Logon ticket.

We are presently at the following patch levels:

Portal: SP2 Patch 29 (6.0.2.29.0)

CM & Collaboration: SP2 Patch 5 (6.0.2.5.0)

SAP J2EE patch level 29

on Solaris 8

The Domino Server is 6.5 on Windows 2003

We have placed the following files as mentioned in the help.

ds_ticket.dll version 1.4.0.0 ,

sapsecu.dll version 5.4.27.0,

wpsso_v3.dll version 6200.1321.0.0

and verify.pse

We made the following settings in the notes.ini in the Domino server

MYSAPDEBUG=true

MYSAPPSEPATH=c:\verify.pse

as well as setting the DSAPI dll path

The Iview was created using App Integrator template with the following

properties.

Authentication Scheme : default

Code link : com.sap.portal.appintegrator.sap.Generic

HTTP request method : POST

URL template fraction for Single Sign-On (SSO2) :

MYSAPSSO2=<Request.SSO2Ticket>

When we access this Iview after logon to EP the following messages are

shown on the Domino console. These messages are visible in the Domino

console approximately a minute after accessing the IView.

  • console messages start ******

Current AuthData: User = ,InCache = 0, PreAuth = 0, Flags = 3F

SSO Ticket found, 592 bytes

Found sap_user = P00100547

DSAPI Filter authenticated as CN=Kevin Hill/O=AsianPaints

  • console messages end ******

However the Iview still show the login page for Domino.

After approximately 2 to 3 minutes a 'right click and refresh' on the

Iview logs the user in.

Has anybody had any success with this method or observed the same problems ?

regards,

Kevin