Skip to Content
avatar image
Former Member

NWDS Will Not Start Because of Wrong JVM

I made the mistake of specifying a 64 bit jvm for NWDS 7.3 so it will not longer start and I don't see how to change the JVM. I looked in SapNetweaverDeveloperStudio.ini and there was no -vm entry so I tried to add one but so far I have not bee able to change the startup from the problem 64 bit JVM.

How do I get NWDS 7.3 to use a specific JVM if it will not even start?

I have attached the error I get when I start NWDS...slightly marked up because I am not used to the new Windows 7 Snipping Tool.

Capture.JPG (79.5 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Nov 05, 2012 at 03:19 PM

    -vm

    <PATH OF YOUR 32BIT JVM>

    add that at the beginning of ini file.

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 05, 2012 at 03:35 PM

    Hi,

    small addition to Jun's post:

    Example of my SapNetweaverDeveloperStudio.ini file. The very first line looks on my end as follows:

    -vm C:\Program Files (x86)\Java\jdk1.6.0_27\bin

    Notice also, it has to be not only 32 bit, but it has to be a JDK, and not a JRE.

    I hope this helps.

    Regards,

    Ervin

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      windows7 should be fine, a related note thisregarding that crosses my mind is:

      #1566977 - NWDS on Windows 7

      Can you please tell me from where you have downloaded the NWDS?

      Please also try this:

      1. stop NWDS (ensure in Task manager there are no related processes running)

      2. add the following paramters to the ini file:

           -clean  (add this to the very beginning of your ini file)

           -vm <your 32 bit JDK1.6 as discussed previously >

      3. start your NWDS

      If it works, then:

      - stop NWDS

      - remove the -clean parameter from the ini file, so at next start it won't be used.

      Let me know if this makes any improvement.

      Thank you and Regards,

      Ervin