Skip to Content

Date Prompts not working in BI4 SP4 for QaaWS and BIWS

Hi Everyone,

To start off, we are grabbing data from an Oracle database.

For SP2 in order to pass date prompts through QaaWS or BIWS, we had to enclose the date field in a to_date statement

ie: to_date('31/1/2011 12:00:00 AM','dd/mm/yyyy hh:mi:ss AM')

However if we try the same in SP4 we get the following error

An internal error occured while calling 'processDPCommandsEx' API. (Error: ERR_WIS_30270)

I was wondering what the new syntax for the date prompts are now.

I tried many different combinations

ie:

1/31/2011 ; 31/1/2011 ; 31/1/2011 12:00:00 AM ; 1/31/2011 12:00:00 AM

And unfortunately none of those worked.

If anyone has a solution to this it would greatly be appreciated.

By the way, in SP2 there was a bug with the WEBI prompt where after the first refresh, dates were showing up as numbers and the only way to fix it was to enclose the date with the to_date function or enter the numerical value of the date. So perhaps when they fixed that bug in SP2, it eliminated the to_date functionality in SP4 and now we can't pass in dates anymore.

Thanks

David

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Nov 01, 2012 at 08:00 PM

    Hi David,

    Following is ADAPT01656652 raised for the date issue which is scheduled to be fixed in SP05.

    You may refer following SAP KBA:

    1763598 - Cannot pass date variable as prompt using BI WSDL in Webi Rich Client or through BI Launchpad

    Thanks,

    Tejas

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 01, 2012 at 05:35 PM

    Hi David,

    I am pretty sure this has been logged as a bug . The issue has surfaced after SP04 on BI 4.0 . I Will post again after i find out more details on this .

    -Aditya

    Message was edited for typo

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 14, 2014 at 03:36 AM

    Yes, me too. The problem is when I use QAAWS as date prompt then I found that the date prompt didn't return the same value.

    e.g:

    Fulldate's value:

    1/1/2012 8:00:00 AM

    But, actually the fulldate's value in my report (WEBI and XCelcius) is 1/1/2012 12:00:00 AM.

    So, when I selected value in QAAWS Answer Prompt, it gaves me NO result (which is return no value because the fulldate data in QAAWS is on 1/1/2012 8:00:00 AM, not 1/1/2012 12:00:00 AM). If this is a bug, in what patch level is it resolved for BI 4.1 SP2?

    Please help me to solve this.

    Thanks!

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.