Skip to Content
avatar image
Former Member

Mismatch in SC versions of NWDI and SLD

Hi Folks,

I'm creating a new track in NWDI. As of now I have defined the Runtime systems and defined the SC's for the NWDI. Currently i need to import the SC into Development tab. The versions of the software components defined in SLD and runtime systems are different. The runtime system was recently upgraded.

Do i need to import SC's version of SLD or runtime system?

Ex ---SAPPCUI_GP(Release 600) has build dependencies of SAP-JEE , SAP_BUILDT , SAP_JTECHS all of version 7.00. This is as per SLD.

the system defined in runtime systems has SAP-JEE, SAP_BUILDT and SAP_JTECHS as 7.02

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Oct 30, 2012 at 02:47 PM

    Hello Anup,

    You must update your SLD Component Repository Information (CR and CIM model content).

    Please proceed as stated in SAP Note: "Note 669669 - Updating the SAP Component Repository in the SLD"

    After updating your SLD, don't forget to synchronize SLD and CMS. Go to CMS administration, domain data and click "Update CMS".

    Regards,

    Daniel Garrido

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 30, 2012 at 04:09 PM

    The build plugins(eg SAP_BUILDT, etc) need to match the runtime.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 31, 2012 at 04:22 PM

    Hi,

    this may help. An old but still valid and good guide:

    How to Migrate Developed Software Components to a New Release in NWDI

    http://scn.sap.com/people/guenter.schiele/blog/2007/02/12/how-to-migrate-developed-software-components-to-a-new-release-in-nwdi

    Best Regards,

    Ervin

    Add comment
    10|10000 characters needed characters exceeded