Skip to Content
author's profile photo Former Member
Former Member

SAPSYSTEMNAME neither in Profile nor Commandline with r3trans

Hello gurus,

Where in Windows or in SAP do I need to set the SAPSYSTEMNAME parameter so I don't see this message with r3trans?

R3trans=>sapparam: SAPSYSTEMNAME neither in Profile nor Commandline with r3trans

Warm Regards,

CM

Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Oct 26, 2012 at 10:44 PM

    Hi Clifton,

    After searching a lot, i found this note relevant to your issue - Note 32785

    Summary

    Symptom

    Various unix programs return the message on startup sapparam(1c): No Profile used.
    sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline

    Additional key words

    Cause and prerequisites

    Many shell programs (example: sapevt) are started with parameters. <program> pf=<profile>or <program> name=<hostame> nr=<instance>
    The program sapparam is started automatically, to test system parameters. If the program is started with the parameters hostname and instance, the following message appears: sapparam(1c): No Profile used.

    Solution

    This message is only a minor flaw that can be simply ignored.

    As specified here, this message can be ignored as this is just a warning and not an error.

    Hope this helps,

    Regards,

    Ashutosh Shukla

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 26, 2012 at 02:31 PM

    R3trans searchs parameters in system environment. So please set SAPSYSTEMNAME in global environment.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 26, 2012 at 08:41 PM

    1)download and replace latest R3trans and check .

    2) run tx se38 >rspfpar report , check SAPSYSTEMNAME

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 30, 2012 at 08:22 PM

    When I run a lot of r3trans commands, it adds unnecessary noise to the output. I will happily add a flag to the r3trans string or use any profile it wants, I just need to know how. ... or is that every customer that uses r3trans will see these informational messages and there is no way to get rid of them?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 26, 2013 at 07:59 PM

    SAPSYSTEMNAME is set properly for <sid>adm and all users. I would prefer not to paste my system envrionment here. Are there a couple of specific variables you are interested in? If anyone has further suggestions for how to suppress this message, I would appreciate it because it is quite annoying. Otherwise, I will take the advice of Ashutosh and ignore it.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Susan,

      What syntax could I use to add the hostname and instance parameters to the R3trans command? I do not find an option with R3trans that allows this. With tp, you can specify pf=, but with R3trans, I found that it ignores additional options.

      R3trans is used in custom scripts for exporting and importing tables for homogenous system copy.

  • Posted on Sep 13, 2013 at 06:12 PM

    Hi Clifton,

    Login with SIDADM and use R3trans -d.

    Regards,

    Himanshu

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.