Skip to Content
0
Former Member
Oct 25, 2012 at 05:58 PM

HTTP Post Action block - Disallowed Key Characters.

152 Views

Hi,

I have a URL given by other team which gives simple xml. It works fine from URL.

i have created transaction with httppost action block and assigned RetunAsXML to output XML variable. I have aslo assigned the same OP from URL to tracer to see the result. It comes as empty .

Then traced ReturnAsString and i see "Disallowed Key Characters" .

Weird thing is that..

When i run this transaction by runner url with user name and password included,it works for the first time i run in new session. i refresh,it doesn't work.

it gives error -

XML document must have a top level element. Error processing resource 'http://host:50100/XMII/Runner?Transaction=<<<>>>...

If don't include user name and password in url ,it gives different error. ( encoding error )

System does not support the specified encoding. Error processing resource 'http://host:50100/XMII/Runner?Transaction=V...

<?xml version="1.0" encoding="UTF-8" standalone="no"?> 

So,it never works from Workbench.

It works from runner url with user name password included in new session for first time and refresh ..doesn't work.

It doesn't work from Runner URL with out user name and password.

It looks like URL is php page.

Any idea on what is wrong with URL or MII ?

Update1:

MII URL with uname and password,

I have noticed that in firefox 15.0.1,deleting cookies every time i refresh,it works.

With I.E 8 ..it doesn't work though after deleting cookies.I had to do file,new session to get it work for the first time.

Update 2:

I tried calling this php url through Ajax by POST and GET method. It just works fine.

Update 3: software engineer ( php developer ) who gave this url said he is using built in PHP object XMLWriter to create this xml.

Thanks

Hari