Skip to Content
0
Oct 25, 2012 at 03:55 PM

Crystal Reports XI crashes using IBM UniData ODBC Drivers

51 Views

I've been using Crystal Reports XI on a PC running Windows 7 for over a year with no issues. My usual work requires an ODBC connection to a UniData server. That has never been an issue until earlier this week. From one day to the next, I started getting the following error every time I tried to do anything with a connection to UniData:

Problem signature:

Problem Event Name: APPCRASH

Application Name: crw32.exe

Application Version: 11.5.12.1838

Application Timestamp: 4b16581e

Fault Module Name: udtodbc.dll

Fault Module Version: 3.1.7.7232

Fault Module Timestamp: 4726415d

Exception Code: c0000005

Exception Offset: 00012f5c

OS Version: 6.1.7601.2.1.0.256.48

Locale ID: 1033

Additional Information 1: 1fc1

Additional Information 2: 1fc163a1c57ae45571bce37d539b233f

Additional Information 3: cc5f

Additional Information 4: cc5fb879edab709590d18cd6b09cdc4b

The error immediately points to udtodbc.dll, the UniData ODBC Drivers. I've tried uninstalling/reinstalling them several times with no luck with Crystal Reports. The thing is, I can make an ODBC connection outside of Crystal Reports. I am able to do so with Excel and with Visual Basic. It has to be Crystal Reports. I've searched and came across http://scn.sap.com/thread/3185770 and http://scn.sap.com/thread/1631062. They mentioning upgrading Crystal Reports XI to the latest Service Pack. Prior to the issue, I wasn't even on R2 and it worked fine with Windows 7. I am now on R2 SP6 (version 11.5.12.1838) but I am still having issues. The threads also mention disabling DEP for crw32.exe which I have done, but didn't help.

Everything works fine on a different workstation running R1. Anybody have any insight?

Thanks,

Gonzalo