Skip to Content
author's profile photo Former Member
Former Member

SAP ME - Automatic printing using ADS

Hi there,

We are using ADS in ME for label printing. I am able to print my label in industrial laser printer which we see in office corners with out a problem .

But when i tried to print in Zebra printer or Brother label printers ...my label doesn't print.

I have configured post complete hook point of my operation to print my label by giving my sy521 activity (copied from original SY521) and document name as user argument.

When i use laser printer in printer name of my sy521 activity and print format as PCL in my document its working properly.

When changed printer to one of Zebra or Brother and changed print format to ZPL in case of zebra and PL,PCL,PDF for Brother ..It creates the print job in queue but it never prints but it say printed after few seconds.

So,problem is i can't get 'automatic printing' working by any of proper label printers we are using. I have changed Print format to all possible inputs..but i doesn't work.

Did you any of you got automatic printing working through ADS??

Thanks

Hari

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    Posted on Oct 25, 2012 at 09:50 AM

    Hi Hari,

    Please make sure that your Zebra printer is installed and configured properly, you may try to print something to your Zebra printer from outside of ME application.

    Also make sure that PRINT_FORMAT=ZPL specified in Document Maintenance for the label


    If you are sure that the printer is ok, please follow SAP note 1548916 "ZPL print format was not possible using PDFObject API" to apply the Netweaver patch. Make sure to download a correct version of the patch in accordance to Netweaver version you have. E.g. if you have Netweaver CE 7.11 SP5 you should download the SP Patch Level for Software Component Version “JAVA FRAMEWORK OFFLINE 7.11” and Support Package “SP005”

    Regards,

    Konstantin

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Sergiy Katerinich

      Thanks Sergiy.

      We are working getting labels working another box which has SP04. And you know about the other problems we are facing through Customer message (oss) .

      I will keep you posted on any progress we make on this issue.

      Thanks

      Hari

  • Posted on Oct 24, 2012 at 08:10 AM

    Hari,

    Please check if your configuration corresponds to the How-To Guide.

    Try turning on saving PDF files to the temporary directory as mentioned in the guide.

    In fact, the guide provides an example of setup for ZPL - see section 5.

    Regards,

    Sergiy

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.