Skip to Content
avatar image
Former Member

Problem integrating SAP MDM and EP

Hello,

I'm trying to connect my SAP MDM to my SAP EP (portal).

My portal is a netweaver 7.3 and I'm using SAP MDM 7.1 (SP 9).

I installed the following business packages on my portal  and followed the installation guide found on http://help.sap.com/saphelp_nwmdm71

BP_MDM_APP          1000.710.730.8.28.20120515105200 SAP AG

BP_MDM_TECH         1000.710.730.8.28.20120515102500 SAP AG

MDM_CONNECTOR   1000.710.711.9.3.20121010231031 MAIN_MD7191xP_C

MDM_ENRICHMENT_CONTROLLER 1000.710.711.6.35.20110831110702 MAIN_MD71611P_C

MDM_EP                   1000.710.711.9.0.20120822211925 MAIN_MD7191xP_C

MDM_JAVA_API        1000.710.0.9.284.20120904094400 SAP AG

MDM_WEB_UI           1000.710.711.4.38.20101027093935 MAIN_MD7171VA_C

I logged on my portal with admistrator user.  I created a new system.  I refered to my SAP MDM server.

I tried to perform a connection test and got the following error messages :

(for quick connection test)
Could not find Connector Factory value: MDM Factory

and  :
(for systems connection tests)

Connection Test for Connectors:
Test Details:
The test consists of the following steps:
1. Retrieve the default alias of the system
2. Check the connection to the back-end application using the connector defined in this system object

Results
Default alias retrieved successfully
Connection failed. Make sure user mapping is set correctly and all connection properties are correct.

I modified the user mapping and I still get the same error.

Could you please advise ?

Thanks in advance

Regards

Hamza

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Nov 16, 2012 at 09:40 PM

    Hi,

    Make sure the BP SP levels align with the MDM SP level. For testing, create an iView (or one of those MDM iViews) and test it. The connection tests are sometimes buggy.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Arun,

      As you specified it, the level of the installed MDM_CONNECTOR was not the right version.  After installation of the correct version of the MDM_CONNECTOR, I could finally create my iviews, even if the test connection reported always the same errors.

      Thanks for your help !

      Regards

      Hamza