Skip to Content
avatar image
Former Member

NW7.31 upgrade error in phase BIND_SUPPORT_PACKAGES

Hi SAP Experts,

Right now we are having EPNW 7.0 SP 16 with ESS/MSS BP installed as following :

BP_ERP5ESS 1.0- BP ERP05 ESS 1.0

BP_ERP5MSS 1.0 - BP ERP05 MSS 1.0

SAPPCUI_GP 600 - SAP PCUI_GP 600

SAP_ESS 600 - SAP ESS 600

BP_ERP5COM 1.0

BP_ERP5ASS 1.0

We need to do EP upgrade to NW7.31 , according to SAP recommendation Note 1698276- SAP Business Suite for SAP NetWeaver 7.31 hub systems ,

we have updated the ESS/MSS package and contents to be EHP4 for ERP 6.00

and I defined the hub systems as well in Solman ,  generated the new stack XML file, then I started the upgrade using SUM tool.

Now I’m getting error in phase BIND_SUPPORT_PACKAGES as following :

+++++++++++++++++

An error has occurred during the execution of the BIND_SUPPORT_PACKAGES phase.

Error while applying support package stacks. See stack trace for details. Error during reinitialize of target components vector. Error while extracting usage type mapping Error while trying to extract product definition from UTL. Could not load usage type data from [/oracle/EPE/sapdata1/SUM/java/tmp/DEPLOYARCHIVES/tc~sl.ut.content.erp.bp_erp.sda, /oracle/EPE/sapdata1/SUM/java/tmp/DEPLOYARCHIVES/tc~sl.ut.content~nw.sda, /oracle/EPE/sapdata1/SUM/java/tmp/DEPLOYARCHIVES/tc~sl.ut.content.erp.xss.sda, /oracle/EPE/sapdata1/SUM/java/tmp/DEPLOYARCHIVES/tc~sl.ut.content.erp.bp_xss.sda]. com.sap.sl.ut.infoprovider.exceptions.UTInfoException: Usage BP-XSS from product ERP has dependancies to usage IDs [1, 111]. But no dependancy usage with id 111 was found in the current product usages! UsageIdsMap is 803=[ Part : name NW-MODEL], 110=[ Part : name BP-XSS], 55=[ Part : name PI-AF], 15=[ Part : name XSS], 12=[ Part : name BP-ERP], 82=[ Part : name CE-VOICE], 83=[ Part : name ADOBE], 80=[ Part : name BASIC], 81=[ Part : name COMP-ENV], 86=[ Part : name CE-APPS], 100=[ Part : name BPM], 85=[ Part : name CE-PROCESS], 302=[ Part : name PI-AEX], 301=[ Part : name PI-AE-SE], 304=[ Part : name BASIC-RA], 90=[ Part : name ESR], 305=[ Part : name ALV-EXPORT], 3=[ Part : name DI], 2=[ Part : name PI], 1=[ Part : name AS], 0=[ Part : name AAS], 7=[ Part : name EPC], 6=[ Part : name BI], 5=[ Part : name EP], 399=[ Part : name JOB-SCHED], 89=[ Part : name IDE-Update-Site] You can find more information in the files /oracle/EPE/sapdata1/SUM/java/log/BIND_SUPPORT_PACKAGES_BSP_04.LOG and ProcessOverview.html.

Use the information provided to troubleshoot the problem. An SAP Note may provide a solution to this problem. Search for SAP Notes with the following key words: com.sap.sdt.j2ee.phases.PhaseTypeBindSupportPackages com.sap.sdt.j2ee.phases.BindSupportPackagesException Error while applying support package stacks. See stack trace for details. BIND_SUPPORT_PACKAGES CONFIG PREPARE NetWeaver Upgrade SAPJup Java Upgrade 

+++++++++++++++++

Can you please help/Advice how to resolve this issue?

Regards,

Sherif

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Oct 23, 2012 at 04:46 PM

    Hi Sherif

    This issue is happening because the Portal Content/SAP XSS Self Services are installed with version ERP 6.0 and not EHP4.

    BP_ERP5ESS 1.0- BP ERP05 ESS 1.0 should be 1.41 and not 1.0

    BP_ERP5MSS 1.0 - BP ERP05 MSS 1.0 should be 1.41 and not 1.0

    SAPPCUI_GP 600 - SAP PCUI_GP 600 should be 603 and not 600

    SAP_ESS 600 - SAP ESS 600 should be 603 and not 600

    BP_ERP5COM 1.0 should be 1.41 and not 1.0

    BP_ERP5ASS 1.0 Ok

    After update the components, you should select all relevant product versions/instances in SMSY and generate a mopz transaction for SAP Netweaver 7.3X.

    Check this wiki below that I wrote to clarify this kind of issue.

    http://wiki.sdn.sap.com/wiki/display/ERP6/SAP+Netweaver+7.3x+hub+systems+upgrade

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Mateus,

      I already  followed the wiki and the included notes to define the system, the current sw components are:

      BP_BIADMIN 60.1 5    - not updated

      BP_ERP5ASS 1.0  sp 17   - updated

      BP_ERP5COM 1.41 sp 6    -updated

      BP_ERP5ESS 1.41  sp6   - updated

      BP_ERP5MSS 1.41 sp 6     -updated

      SAPPCUI_GP 603  sp6      -updated

      SAP_ESS 603  sp 6      -updated

      SAP_MSS 600 sp17    -updated

      LSOCP 604 sp7    -updated

      The system has been defined in SMSY/LMDB under the following products:

      1- SAP Netweaver 7.0  selected instances:
      [Application Server Java, Adobe Document Services, Development Infrastructure, EP Content, EP Core, Enterprise Portal]

      2-SAP ERP 6.0  selected instances:

      [ Portal Content , SAP NW - EP Core, SAP XSS (Self Services) ]

      3- EHP4 for ERP 6.0 selected instances:

      [Portal Content Common, Portal Content  , Portal Content Self Services, SAP Learning Sol-Frontend CP, SAP XSS (Self Services)]

      ----------------------------------------------------------------------------------------------------------------

      I was able to generate the XML before the SMSY get updated from LMDB ,

      But now i'm not able to generate XML stack fie , due to the following error:

      There is no OS/DB dependent file.

      ++++++++error details:+++++++
      Multiple component versions exist for system.
      CL_FREETEXT_MESSAGE

      Multiple component versions exist for system.

      Message no. MOPZ_MSG_DELTA_CALC005

      +++++++++++++End of error++++++++++

      So I stcuk again.

      Regards,

  • Oct 22, 2012 at 11:46 PM

    Hello Sherif,

    the issue is with the XML stack file, which did not provide the dependent pacakge for one of the components of BP-XSS (it looks like it is BP_ERP).

    "Usage BP-XSS from product ERP has dependancies to usage IDs [1, 111]. But no dependancy usage with id 111 was found in the current product usages!"


    Please ensure your SolMan is patched with the latest SPs and updated via SLD from the Java system, kindly generate a new stack file in MOPZ

    Best regards,

    Tomas Black

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Sherif,

      this error takes place when you assing the incorrect system to your backend ERP in transaction MOPZ, by the time you were creating the XML stack file.

      I'm asking a MOPZ expert colleague to take a look at this issue also. IN the meantime, please attach the XML stack file you used for this upgrade and, if possible, some screenshots of MOPZ with the systems assignment for your ERP.

      Best regards,

      Tomas Black

  • Oct 22, 2012 at 10:55 AM

    Hi

    Could you please post contents of BIND_SUPPORT_PACKAGES_BSP_04.LOG

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Mahesh Kumar Mukkawar

      Hi Mahesh,

      the system info:

      sap.com  BI-WDALV 7.00 SP16 (1000.7.00.16.0.20080610184628)  SAP AG MAIN_APL70VAL_C 20081120185210  sap.com DI_DTR  7.00 SP16 (1000.7.00.16.0.20080610190347)  SAP AG  MAIN_APL70VAL_C  20081120190038  sap.com BI_UDI  7.00 SP16 (1000.7.00.16.0.20080610120325)  SAP AG  SAP AG  20081120153758  sap.com KM-KW_JIKS  7.00 SP16 (1000.7.00.16.0.20080610120928)  SAP AG  SAP AG  20081120150948  sap.com SAP_JTECHF  7.00 SP16 (1000.7.00.16.10.20081103102814)  SAP AG  SAP AG  20081121092614  sap.com VCKITGP  7.00 SP16 (1000.7.00.16.0.20080610174113)  SAP AG  SAP AG  20081120165617  sap.com CAF-KM  7.00 SP16 (1000.7.00.16.0.20080610185206)  SAP AG  MAIN_APL70VAL_C  20081120195005  sap.com VCBASE  7.00 SP16 (1000.7.00.16.0.20080610174033)  SAP AG  SAP AG  20081120195138  sap.com WDEXTENSIONS  7.00 SP16 (1000.7.00.16.0.20080610185851)  SAP AG  MAIN_APL70VAL_C  20081120195348  sap.com LM-TOOLS  7.00 SP16 (1000.7.00.16.2.20080905092231)  SAP AG  MAIN_APL70P16_C  20081121094555  sap.com SAP-EU  7.00 SP16 (1000.7.00.16.1.20080827140457)  SAP AG  MAIN_APL70P16_C  20081121094634  sap.com ADSSAP  7.00 SP16 (1000.7.00.16.1.20081023093102)  SAP AG  SAP AG  20110505223524  sap.com VCKITBI  7.00 SP16 (1000.7.00.16.0.20080610173447)  SAP AG  SAP AG  20081120165558  sap.com JLOGVIEW  7.00 SP16 (1000.7.00.16.0.20080610110700)  SAP AG  SAP AG  20081120134744  sap.com SAP-JEE  7.00 SP16 (1000.7.00.16.2.20080827152832)  SAP AG  SAP AG  20081121092509  sap.com DI_CMS  7.00 SP16 (1000.7.00.16.1.20080804114523)  SAP AG  MAIN_APL70P16_C  20081121095237  sap.com UWLJWF  7.00 SP16 (1000.7.00.16.3.20081007142416)  SAP AG  SAP AG  20081121095304  sap.com NET-PDK  7.00 SP16 (1000.7.00.16.0.20080610173931)  SAP AG  SAP AG  20081120182552  sap.com EP-PSERV  7.00 SP16 (1000.7.00.16.1.20080721134254)  SAP AG  SAP AG  20081121093905  sap.com BI-BASE-S  7.00 SP16 (1000.7.00.16.30.20080819105147)  SAP AG  SAP AG  20081121094330  sap.com BI_MMR  7.00 SP16 (1000.7.00.16.1.20080813134353)  SAP AG  SAP AG  20081121094416  sap.com CAF  7.00 SP16 (1000.7.00.16.2.20081020063121)  SAP AG  MAIN_APL70P16_C  20081121095140  sap.com EPBC2  7.00 SP16 (1000.7.00.16.1.20080728134355)  SAP AG  SAP AG  20081121093916  sap.com UMEADMIN  7.00 SP16 (1000.7.00.16.0.20080610192745)  SAP AG  MAIN_APL70VAL_C  20081120162421  sap.com BI-IBC  7.00 SP16 (1000.7.00.16.0.20080610172906)  SAP AG  SAP AG  20081120165518  sap.com RTC-STREAM  7.00 SP16 (1000.7.00.16.0.20080610173948)  SAP AG  SAP AG  20081120165538  sap.com VCKITXX  7.00 SP16 (1000.7.00.16.0.20080610174113)  SAP AG  SAP AG  20081120165637  sap.com JSPM  7.00 SP16 (1000.7.00.16.1.20080904124600)  SAP AG  SAP AG  20081120093928  sap.com KMC-BC  7.00 SP16 (1000.7.00.16.0.20080610173803)  SAP AG  SAP AG  20081120191150  sap.com LM-PORTAL  7.00 SP16 (1000.7.00.16.0.20080610185557)  SAP AG  MAIN_APL70VAL_C  20081120191505  sap.com BIWEBAPP  7.00 SP16 (1000.7.00.16.30.20080819105227)  SAP AG  SAP AG  20081121093720  sap.com CORE-TOOLS  7.00 SP16 (1000.7.00.16.0.20080610120618)  SAP AG  SAP AG  20081120134337  sap.com BI-REPPLAN  7.00 SP16 (1000.7.00.16.0.20080610184618)  SAP AG  MAIN_APL70VAL_C  20081120185043  sap.com RTC  7.00 SP16 (1000.7.00.16.0.20080610173947)  SAP AG  SAP AG  20081120182651  sap.com VCFLEX  7.00 SP16 (1000.7.00.16.0.20080610174104)  SAP AG  SAP AG  20081120184238  sap.com VCFRAMEWORK  7.00 SP16 (1000.7.00.16.0.20080610174113)  SAP AG  SAP AG  20081120184418  sap.com CAF-UM  7.00 SP16 (1000.7.00.16.0.20080610191453)  SAP AG  MAIN_APL70VAL_C  20081120150729  sap.com SAP_JTECHS  7.00 SP16 (1000.7.00.16.12.20081103102943)  SAP AG  SAP AG  20081121094908  sap.com EP-WDC  7.00 SP16 (1000.7.00.16.0.20080610152000)  SAP AG  SAP AG  20081120191039  sap.com EPBC  7.00 SP16 (1000.7.00.16.0.20080610173602)  SAP AG  SAP AG  20081120150906  sap.com BP_BIADMIN  60.1 SP5 (1000.60.1.5.0.20060118134900)  SAP AG  SAP AG  20080207105854  sap.com SAP_MSS  600 SP17 (1000.600.0.17.0.20100303054939)  SAP AG  MAIN_ERP05VAL_C  20121017075719  sap.com SAP_BUILDT  7.00 SP12 (1000.7.00.12.0.20070506022600)  SAP AG  SAP AG  20071104101825  sap.com EP_BUILDT  7.00 SP12 (1000.7.00.12.0.20070508084000)  SAP AG  SAP AG  20071104104154  sap.com IDMIC  7.00 SP5 (1000.7.00.5.1.20101020160218)  SAP AG  MAIN_IDM700_C  20101123184318  sap.com SAPPCUI_GP  603 SP6 (1000.603.0.6.2.20100803082033)  SAP AG  MAIN_ERP53PAT_C  20121017064626  sap.com KMC-COLL  7.00 SP16 (1000.7.00.16.1.20080725105124)  SAP AG  SAP AG  20081121094007  sap.com DI_CBS  7.00 SP16 (1000.7.00.16.1.20080714100510)  SAP AG  MAIN_APL70P16_C  20081121093732  sap.com BP_MDM_APP  7.1 SP3 (1000.7.1.3.51.20091001054439)  SAP AG  SAP AG  20091010171356  sap.com BP_MDM_TECH  7.1 SP3 (1000.7.1.3.51.20091001053549)  SAP AG  SAP AG  20091010171508  sap.com MDM_JAVA_API  7.1 SP3 (1000.7.1.3.51.20091001053634)  SAP AG  SAP AG  20091010171703  sap.com SAP-JEECOR  7.00 SP16 (1000.7.00.16.10.20090702064251)  SAP AG  SAP AG  20090713171638  sap.com BASETABLES  7.00 SP16 (1000.7.00.16.0.20080610120226)  SAP AG  SAP AG  20081120134031  sap.com KMC-CM  7.00 SP16 (1000.7.00.16.3.20081014082552)  SAP AG  SAP AG  20081121094424  sap.com BP_ERP5MSS  1.41 SP6 (1000.1.41.6.0.20100412095904)  SAP AG  MAIN_ERP54VAL_C  20121017101848  zsabic.com  ZCOMPONENT-SABIC  1.0 SP0 (20071028101111)  EPD EPD_ZTRACK_C 20071028101111  sap.com BP_ERP5ESS  1.41 SP6 (1000.1.41.6.0.20100412095900)  SAP AG  MAIN_ERP54VAL_C  20121017104144  sap.com SAP_ESS  603 SP6 (1000.603.0.6.8.20100907050136)  SAP AG  MAIN_ERP53PAT_C  20121017143825  sap.com LSOCP  604 SP7 (1000.604.0.7.0.20100719151453)  SAP AG  SAP AG  20121020063923  sap.com BP_ERP5COM  1.41 SP6 (1000.1.41.6.0.20100412095943)  SAP AG  MAIN_ERP54VAL_C  20121017103630  sap.com BP_ERP5ASS  1.0 SP17 (1000.1.0.17.0.20100302100422)  SAP AG  MAIN_ERP05VAL_C  20121017105313