Skip to Content
avatar image
Former Member

Eclipse Neon and UI5

After Installing Eclipse Neon and UI5 Plugin - I still cannot get the autocomplete while coding. Please advice what is missing?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Jan 05, 2017 at 10:02 AM

    Hi Kasee Palaniappan ,

    same problem i faced with ECLIPSE NEON version..

    Install ECLIPSE MARS version it is working without any issue

    Regards,

    Vinod Kumar.

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 01, 2017 at 11:20 AM

    1.Confirm the required plugins are installed properly by doing following:

    Eclipse > Help > Install New Software > under https://tools.hana.ondemand.com/mars > UI Development Tools for HTML5 is installed.

    2.See if your settings are correct also:

    Window -> Preferences -> Java -> Editor -> content assist. See if the "completion inserts" is checked off along with anything else there you want to help auto complete.

    I have faced the same issue, So once all above are configured try restarting the eclipse and type sap.m.Bu then press : Ctrl + Space.

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 01, 2017 at 12:13 PM

    Generally, if plugins are installed the code auto-complete should work.

    If nothing works, do the default option to fix software issues: ..... Restart the machine. :)

    Regards,

    Sharath

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 04 at 07:21 PM

    In my case, the autocompletion did not work because sap.ui.core library was missing in the SAPUI5 Core Libraries list. I am still trying to figure out why the installation process of the "UI Development Tools for HTML5" did not take care of it and how to add this library manually (more where to get it)

    Add comment
    10|10000 characters needed characters exceeded