Skip to Content
avatar image
Former Member

RFC call from XI to R/3 bapi only returns part data - SOLVED

We are currently on R/3 Enterprise and are using XI 3.0.

We are currently working on an RFC call from XI to a custom bapi from sap r/3 and return this data back to XI to display in a web front end.

My colleague has created a bapi which works when we test in R/3 - all data is displayed correctly.

When we call from XI (using http client) only certain data is displayed in the xml file.

We wish to display an SD billing document in the web front end, but wish to include the customer name and address and the parts of the accounting document relating to outstanding amount.

For this reason, the standard bapi BAPI_BILLINGDOC_DISPLAY does not fit our requirements.

Short of posting all the code and table definitions etcetera, can anyone suggest why this works in R/3 but not from XI?

Message was edited by: Barry Neaves

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Jul 20, 2005 at 01:12 PM

    This has now been resolved and the issue/problem was so simple I feel embarrassed about it....

    Problem - Pass Invoice number and customer number to SAP and return that invoice to frontside web app...

    Solution - add leading zeros to customer number (10 characters) now it works......

    Simple yet frustrating.... All those hours of debugging...... RFC traces..... all sorted now!!!

    Thanks for everyone's input.....

    Add comment
    10|10000 characters needed characters exceeded