Skip to Content

I cannot display User-Defined Fields in SAP B1. Why?

Dear All,

Please see the attached picture which explains my problem.

Any answers, hints or suggestions are most welcome.

Thanks.

Leon Lai

capture.jpg (134.5 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

8 Answers

  • Jan 04, 2017 at 11:12 AM

    Hi,

    Check this thread, if its something similar to the following thread:

    https://archive.sap.com/discussions/thread/1165351

    Regards,

    Jitin

    Add comment
    10|10000 characters needed characters exceeded

    • Hi, Jitin

      Thanks for your reply.

      Unfortunately, my problem is different.

      It is NOT possible for me to check the check box on the SAP menu. It simply does not work.

      With my existing company, it is possible; but it is not possible with the newly created company.

      Best Regards,

      Leon

  • Jan 04, 2017 at 11:44 AM

    Hi,

    Can you confirm if the issue is happening with a single user or all the users?

    If it is happening with a new user as well?

    Also, are there UDT's as well in the database?

    Regards,

    Jitin

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 04, 2017 at 12:01 PM

    Hi, Jim

    >> Can you confirm if the issue is happening with a single user or all the users?

    With ALL existing users, including Manager.

    I have not tried with a new user.

    >> Also, are there UDT's as well in the database?

    We do not use UDT. We use UDF in SAP tables (e.g in Marketing Documents)

    For ex. in OVPM, we create a UDF. This is suppose to show up on the SAP Screen, so users can input data.

    As for UDFs, I confirm that they exist in the new company (database).

    Note: We are familiar with UDF, as we use them everyday.

    It works with the existing company, but not with the newly created one.

    Which leads me to suspect that maybe our SAP consultant has disabled the menu (viz. Display UDF).

    My question is: How can someone disable this SAP Menu? (and re-enable it?)

    Or could it be that SAP has been corrupt?

    Thanks

    Leon

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 04, 2017 at 12:19 PM

    Hi,

    Under the tools option, do you get to see the UDF defined ?

    Regards

    Pradnya

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 04, 2017 at 01:43 PM

    Hi,

    Does the user has authorization on User Defined Fields Management.

    Regards

    Pradnya

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 09, 2017 at 11:14 AM

    Hi,

    when the UDFs are created they fall under a category "General" by default. Later on user can make them fall under different groups to make them document specific.

    Guess, something gone wrong with those categories.

    Regards

    Pradnya

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 09, 2017 at 01:04 PM

    Hi Leon,

    If this feature were disabled, you would not even be able to set the check box. It looks like you can set the check box, but it just doesn't do what it is supposed to do?

    You say the new company is nearly identical to an existing one. Did the consultant copy the existing company database to the new one? Did he/she use a self-made tool for this? If so, I think your best bet is to talk to the consultant. it is quite possible that this is a known issue with their tool, and they may already have a solution worked out. At any rate, they should be contractually responsible for delivering a fully functional company database.

    Regards,

    Johan

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 10, 2017 at 07:25 AM

    Hi,

    If no UDF created for document, you can not view check box for User Defined Field under view. Make sure UDF was created for documents.

    Regards,

    Nagarajan

    Add comment
    10|10000 characters needed characters exceeded