Skip to Content
0
Former Member
Oct 03, 2012 at 11:50 AM

Integration Process - Stuck in an Error State ?

14 Views

Hi,

I created an integration process in our development environment and it worked perectly. However, for reasons unclear one day it just stopped working and all requests to it timed out. I therefore simply copied the process and created a new series of configuration objects to match. Again it worked perfectly. This shows me there is nothing wrong with the IP. After some thinking I suspected what might be happening is:

IP works fine

Message is passed into IP which causes an error

Error generated is unhandled

IP stops working

i.e. if the IP gets an unhandled error it appears to get stuck in some sort of error state and is unusable.

To prove this I took a working copy, passed invalid data to it and indeed it did break it.

I will need to look at ensuring there are no unhandled errors in future. In the meantime my question is....how do you get the IP out of this apparent error state ? Is there something you can clear. At the moment when an IP stops working due to an unhandled error it never works again. This can't be right. There must be something I can do to get it working again.

Cheers,

Paul Clements.