Skip to Content
author's profile photo Former Member
Former Member

delete models/package.... in Studio

Hi,

when I try to delete an Attr. view which standalone (not being used in any analytical view) using Object owner or with SYSTEM, comes an error

Deletion of object ...........

unsupported what for action==delete

want to clean up models, packages not necessary anymore

regards

Ahmad

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

9 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Oct 01, 2012 at 07:13 PM

    Hi Ahmed,

    I can delete atrribute view. Have you tried to delete the whole package without delte the attr. view?

    Have you got the error when attri. view or package?

    Can you please try to delete it again.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 01, 2012 at 07:21 PM

    Check to see whether anything in your authorization changed recently. Regards, Rama

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 01, 2012 at 08:59 PM

    Dear Ahmad,

    Can you give us some information about your installation (Revision of HANA DB, Studio, Client)?

    Best Regards,
    Marcel

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      HANA DB is on Rev. 28, Studio 33

      I've autho. nearly same like SYSTEM.

      If try to directly delete Package then comes error: Repository, Package is not empty (contains dev. objects)

      Tried to delete as object owner and also using SYSTEM but no result.

      one thing that I just tested is: when I create a new package without further creating any attr. view then can can delete it

      regards

      Ahmad

  • author's profile photo Former Member
    Former Member
    Posted on Oct 02, 2012 at 01:34 PM

    Hi all,

    we have the same problem here with DB Rev. 28, Studio Rev. 35.

    We can perform the deletion without problem using Studio Rev. 32 or Rev. 28.

    Best regards,

    Christoph

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 04, 2012 at 05:42 PM

    Hi A Ahmad,

    I faced this probelm since rev21 (now it's better on rev37). There are some utils on phyton_support that correct this and make the objects showup so you can delete it. But before you do it you need to open a ticket at SAP as scripts aren't to used without express request from SAP Support.

    Regards, Fernando Da Ros

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 29, 2012 at 08:28 AM

    I ran into the same issue. But after delete all the active objects and inactive objects, the package can be totally deleted.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 20, 2012 at 10:43 PM

    We upgraded to service pack 4 on the HANA Server and at the same time uninstalled the client and studio, and then reinstalled to upgraded client (32 Bit version 38. And now we seem to having the same issue.

    It is inconsistent, some items we can delete and some items we cannot delete. At the moment there is one attribute, one analytic and one script that cannot be deleted.

    Has anybody made any progress on this issue?

    Thanks

    David Bullock

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 12, 2013 at 10:22 AM

    Hi Guys,

    I created some XS and SAPUI5 Projects in HANA Studio, now when I try to delete these projects/ packages, i get an error "Repository: package is not empty (contains development Objects)" but this package seems to be empty as I can't see any thing inside the package. May be their are some invisible objects inside the package but I can't see them.

    I am using HANA version 1.0.49. I also tried the following statement do delete the package 'a1project' content:

    DELETE * FROM _SYS_REPO.PACKAGE_CONTENT WHERE PACKAGE_ID = 'a1project';

    but I am getting the error: "sql syntax error: incorrect syntax near "*""

    and when I try this statement:

    DELETE from _SYS_REPO.PACKAGE_CONTENT WHERE PACKAGE_ID = 'a1project';

    then I am getting error: "Could not find table/view PACKAGE_CONTENT in schema _SYS_REPO"

    Can some one tell me how to delete this package.

    Thanks and best regards.

    Fahad

    Add a comment
    10|10000 characters needed characters exceeded

    • Question ..... I have the same thing here. Our Hana is on 58 and my studio is 60.

      I have some at_views in package_1 that I had moved to package_2.

      When I exported them in my transport I found that the objects in package_2 were included in my package_1 output even though they were not in my du.

      I then moved "all objects" from package_1 to package_2 and still they showed up.

      I tried to delete package_1 and I could not.

      I deleted the objects in package_1 from "_SYS_BIC"

      I see that I have contents of package_1 objects in "_SYS_REPO.ACTIVE_OBJECTS".

      I can not exe "delete from "_SYS_REPO"."ACTIVE_OBJECT" where "PACKAGE_ID = 'package_1' " because of security.

      When I activate an object in package_2 and exe:

      "select * from "_SYS_REPO"."ACTIVE_OBJECT" order by 2"

      then I see my object in BOTH package_1 and package_2 !!!!

      That is why I was getting bad content in my export.

      Anyone know how I solve this without getting the basis group to exe that delete command (which they wont want to do) ?

      Mike

  • Posted on Jul 09, 2016 at 11:04 AM

    This message was moderated.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.