Skip to Content
author's profile photo Former Member
Former Member

Crystall Reports 2011 Crashing HELP PLEASE

HI

Just recently, when ever i create a NEW report, and go to add more then 1 table to my report.

CR Crashes with the "windows message"

“Crystal reports has stopped working. A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.”

how can i work out what is causing this ?

its getting very frustrating as i have already lost A LOT work when it crashes.

i am running Windows 7

and the data is on our IBM server and connecting via ODBC connection to a Progress Data base.

any help would be much appreciated

Thanks

Mark


Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on Sep 27, 2012 at 06:35 AM

    Hi Mark,

    This is known issue. You may refer to this SAP Note for the resolution: 1621593 - Crystal Reports 2011 crashes when trying to link tables in DB2 iSeries

    If you're not able to access the SAP Note; here's what it says:

    Cause

    ODBC Driver Access permission issue

    Resolution

    The following registry key resolves the problem:

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SAP BusinessObjects\Suite XI 4.0\Crystal Reports\Database\ODBC\
    "AccessMode" as a Reg_DWORD 0x00000000 (0)

    Here are the steps:

    1. Go to Registry Editor (Click Start > Run > type “regedit” > OK)
    2. Navigate to :

    for Crystal Reports 2011 on 64 bit machine
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SAP BusinessObjects\Suite XI 4.0\Crystal Reports\Database

    for Crystal Reports 2011 on 32 bit machine
    HKEY_LOCAL_MACHINE\SOFTWARE\SAP BusinessObjects\Suite XI 4.0\Crystal Reports\Database

    for Crystal Reports 2008 on 64 bit machine
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SAP BusinessObjects\Suite 12.0\Crystal Reports\Database

    for Crystal Reports 2008 on 32 bit machine
    HKEY_LOCAL_MACHINE\SOFTWARE\SAP BusinessObjects\Suite 12.0\Crystal Reports\Database


    3. Right click the “Database” registry key > select New > Key > name the key “ODBC”

    4. Right click the “ODBC” key > select New > DWord value > name it “AccessMode”

    5. Make sure the value is default: 0x00000000 (0)

    6. Restart the Crystal Reports and try again

    Let me know if this helped!

    -Abhilash

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.